YouTube Videos not playing in Firefox Infinite loading

RESOLVED DUPLICATE of bug 1335512

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1335512
a year ago
a year ago

People

(Reporter: Michael Ellis, Assigned: (default assignee for unassigned bugs. does not receive bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

63.33 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
69.05 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
1011.98 KB, image/png
Details
1.26 MB, image/png
Details
8.84 KB, application/json
Details
(Reporter)

Description

a year ago
Created attachment 8850767 [details]
YT debug info Mar 23.docx

Numerous times over the past month, I have noticed youtube videos (both on YouTube's site and embedded videos on external sites) failing to load, play, Resume. When this occurs I have successfully been able to paste the hyperlink into another browser (Safari) and have the video start as expected.   


Firefox Version: 53.0b4 (64-bit)
Beta Update Channel 
Machine: Mid 2014 MacBook Pro 
Software  OS X 10.9.5 (13F34)
(Reporter)

Comment 1

a year ago
Placing NI on AJones from media team
Flags: needinfo?(ajones)
(Reporter)

Comment 2

a year ago
Created attachment 8850769 [details]
Firefox  YouTube Debug info Mar 22.docx
Assignee: nobody → mellis
(Reporter)

Comment 3

a year ago
Created attachment 8850770 [details]
Screen Shot YT Bug Mar 23.png
(Reporter)

Updated

a year ago
Assignee: mellis → mozbugs-build
(Reporter)

Comment 4

a year ago
Update: Restarting Firefox fixes this issue and videos will play normally.   (but try explaining that to a frustrated user)
Jean-Yves - any ideas?
Component: Untriaged → Audio/Video: Playback
Flags: needinfo?(ajones) → needinfo?(jyavenard)
Product: Firefox → Core
Can you reproduce the issue consistently?

any STR available?

From the stats for nerds screenshot, issue appears network related. No data was loaded..

When you say you could copy the link and open it in a new browser.

Wouldn't that do the same in Firefox (that is open a new windows with Command-N and paste the link in it) ?

Even a refresh should do...

Having said that, I've had similar issues with YouTube lately, but on my iOS (both iPad and iPhone). And for that we have no control over. Could be a YouTube issue
Flags: needinfo?(jyavenard)
(Reporter)

Comment 7

a year ago
Seems to be reproducing. I just read your comment today, then attempted to load a random video in Firefox.   Video did not play.   Video loaded as expected in Safari (see picture).  Attempted to load video in new Firefox window - no luck.  Attempted to load video in new private window in Firefox - no luck. 

Solution - Restarting Firefox
(I will try to keep a mental-eye-out for STR and provide if I am able to identify those)
(Reporter)

Comment 8

a year ago
Created attachment 8852570 [details]
YouTube 2017-03-29 at 9.42.40 AM.png
YouTube doesn't serve the same content to,Firefox and to Safari.

Safari will get mp4 with AAC and h264.
Firefox will get webm with opus and VP9

You can check by going to YouTube.com/html5

Have you modified any prefs? Do you have extensions installed? Retry in safe mode.

Also please post the output of about:support

Comment 10

a year ago
Created attachment 8855085 [details]
about-support.json

I can reproduce this.
It happens randomly, so I would say that it is not (always?) related to video type youtube sends to Firefox.

I can usually reproduce this after a tab with video is been opened for a while, but video is paused.
This includes laptop sleep and wake sequences.

Once the issue appears, I cannot play videos in Youtube, Vimeo and Facebook.
Try setting media.mediasource.webm.enabled=true and see if that fixes YouTube.

Comment 12

a year ago
This happens to me when I plug or unplug my headphones or even just bump into it while adjusting my laptop. Please confirm if this is the cause for you.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1335512
You need to log in before you can comment on or make changes to this bug.