Status

www.mozilla.org
Pages & Content
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: jpetto, Assigned: agibson)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

a year ago
Create a simple landing page for Firefox Focus prior to the Android release (4/5?).

Can use /firefox/ios/ page as rough template. Grab copy from Apple App store [1] description.

Note - may need to do some URL wizardry for de locale. See Focus/privacy PR [2] for more info.


[1] https://mzl.la/2fGnsyD
[2] https://github.com/mozilla/bedrock/pull/4497
(Reporter)

Updated

a year ago
Assignee: nobody → jon
:jpetto, I cc'd Mike Han, who can provide content for this page. Can you link here to the demo page? And do we have fixed specs for art, or are they still evolving? 

Thanks!
Flags: needinfo?(jon)
Though Jon filed this bug and started work on a page for Focus, it has since been rolled in with all the other redesigned product pages so this is probably on my plate now. My (still very rough) version is at https://bedrock-demo-craigcook.us-west.moz.works/en-US/firefox/focus/

No solid art specs yet, that is indeed still evolving. I'm sure we'll at least need product screenshots in both English and German to cover the Focus/Klar situation.
Flags: needinfo?(jon)
(Reporter)

Comment 3

a year ago
Noting that we will most likely need a custom URL for /de/ locale - /firefox/klar/.

(We did this with /privacy/ URLs a while back [1].)


[1] https://github.com/mozilla/bedrock/commit/35a5bbc44c9dc6781b048636875468acc16a2da0

Comment 4

a year ago
Hey there.  FYI, Fabio will be taking the leading on that page - providing content and approvals.
Flags: needinfo?(frios)

Comment 5

11 months ago
Created attachment 8877806 [details]
FF-Focus-Page_Hero.png

large header image
Flags: needinfo?(frios)

Comment 6

11 months ago
Created attachment 8877807 [details]
FF Focus Hub Page_Feature Images-01.png

feature graphic #1

Comment 7

11 months ago
Created attachment 8877808 [details]
FF Focus Hub Page_Feature Images-02.png

feature graphic #2

Comment 8

11 months ago
Created attachment 8877809 [details]
FF Focus Hub Page_Feature Images-03.png

feature graphic #3

Comment 9

11 months ago
Here's the copy, we are still finalizing. I'll ping when 100% approved.

https://docs.google.com/document/d/1JL-tiArP3gRm3EMg23lQdUzDfy2vcsuzxLcBIOAsW9w/edit#
Flags: needinfo?(agibson)
(Assignee)

Updated

11 months ago
Assignee: jon → agibson
Status: NEW → ASSIGNED
Flags: needinfo?(agibson)
(Assignee)

Comment 10

11 months ago
Created attachment 8878032 [details] [review]
GitHub pull request
(Assignee)

Comment 11

11 months ago
WIP demo while we wait for final copy:

https://bedrock-demo-agibson.us-west.moz.works/en-US/firefox/focus/

Fabio, a few things I need:

1.) App Store URL for Focus (including any utm params you may want).
2.) Play Store URL for Focus (including any utm params).
3.) I also added Focus to the global nav and sub nav menus. Should I use the string "Focus", or "Focus Browser" for the navigation?

Thanks!
Flags: needinfo?(frios)
(Assignee)

Comment 12

11 months ago
Oh, I also added the blog tags: ['privacy', 'mobile', and 'featured']. 

Please let me know if you would like something different here.

Comment 13

11 months ago

(In reply to Alex Gibson [:agibson] from comment #11)
> WIP demo while we wait for final copy:
> 
> https://bedrock-demo-agibson.us-west.moz.works/en-US/firefox/focus/
> 
> Fabio, a few things I need:
> 
> 1.) App Store URL for Focus (including any utm params you may want).
https://app.adjust.com/b8s7qo?campaign=&adgroup=&creative=iOS&fallback=https://itunes.apple.com/us/app/id1055677337?mt=8
> 2.) Play Store URL for Focus (including any utm params).
https://app.adjust.com/b8s7qo?campaign=moz.org&adgroup=Focus&creative=android
> 3.) I also added Focus to the global nav and sub nav menus. Should I use the
> string "Focus", or "Focus Browser" for the navigation?
Please use Focus Browser
> 
> Thanks!
Flags: needinfo?(frios)

Comment 14

11 months ago
Alex, we made changes to copy in the metadata title and description, and to section 3.

Elvin reviewed, but it turns out I also had to send to Marshall. I don't expect changes, but not 100% that we won't need to tweak a word. 

How's timing? If we need to make a minor copy edit is it still realistic to get live on Tuesday AM PST?
Flags: needinfo?(agibson)
(Assignee)

Comment 15

11 months ago
(In reply to Fabio Rios [:frios] from comment #14)
> How's timing? If we need to make a minor copy edit is it still realistic to
> get live on Tuesday AM PST?

Yep, that shouldn't be a problem. Thanks
Flags: needinfo?(agibson)
(Assignee)

Comment 16

11 months ago
(In reply to Fabio Rios [:frios] from comment #13)
> 
> (In reply to Alex Gibson [:agibson] from comment #11)
> > WIP demo while we wait for final copy:
> > 
> > https://bedrock-demo-agibson.us-west.moz.works/en-US/firefox/focus/
> > 
> > Fabio, a few things I need:
> > 
> > 1.) App Store URL for Focus (including any utm params you may want).
> https://app.adjust.com/b8s7qo?campaign=&adgroup=&creative=iOS&fallback=https:
> //itunes.apple.com/us/app/id1055677337?mt=8
> > 2.) Play Store URL for Focus (including any utm params).
> https://app.adjust.com/b8s7qo?campaign=moz.org&adgroup=Focus&creative=android
> > 3.) I also added Focus to the global nav and sub nav menus. Should I use the
> > string "Focus", or "Focus Browser" for the navigation?
> Please use Focus Browser
> > 
> > Thanks!

https://app.adjust.com/b8s7qo?campaign=moz.org&adgroup=Focus&creative=android

This seems to redirect me to iTunes and not the Play Store. It also doesn't seem to contain a fallback parameter like the iOS URL.

Comment 17

11 months ago
> https://app.adjust.com/b8s7qo?campaign=moz.org&adgroup=Focus&creative=android
> 
> This seems to redirect me to iTunes and not the Play Store. It also doesn't
> seem to contain a fallback parameter like the iOS URL.

I see that. Getting confirmation from Mike. Will get back to you shortly.

Also, Marshall reviewed and cleared with one minor change to the main subhead. Can you replace with the below?:

<H1> Firefox Focus Browser
<Subhead> Keep it private with automatic ad blocking and tracking protection on iOS and Android.
Flags: needinfo?(agibson)
(Assignee)

Comment 18

11 months ago
(In reply to Fabio Rios [:frios] from comment #17)
> > https://app.adjust.com/b8s7qo?campaign=moz.org&adgroup=Focus&creative=android
> > 
> > This seems to redirect me to iTunes and not the Play Store. It also doesn't
> > seem to contain a fallback parameter like the iOS URL.
> 
> I see that. Getting confirmation from Mike. Will get back to you shortly.
> 
> Also, Marshall reviewed and cleared with one minor change to the main
> subhead. Can you replace with the below?:
> 
> <H1> Firefox Focus Browser
> <Subhead> Keep it private with automatic ad blocking and tracking protection
> on iOS and Android.

Done, thanks
Flags: needinfo?(agibson)

Comment 19

11 months ago
> https://app.adjust.com/b8s7qo?campaign=moz.org&adgroup=Focus&creative=android
> 
> This seems to redirect me to iTunes and not the Play Store. It also doesn't
> seem to contain a fallback parameter like the iOS URL.

Alex, I confirmed with mhan that those are the correct URLs. Because it's not live yet, it's going to default to redirect to iOS. Once they publish the Google Play page on Tuesday, all will work fine.

So, it looks like we are all set. Thanks!
Flags: needinfo?(agibson)
(Assignee)

Comment 20

11 months ago
(In reply to Fabio Rios [:frios] from comment #19)
> > https://app.adjust.com/b8s7qo?campaign=moz.org&adgroup=Focus&creative=android
> > 
> > This seems to redirect me to iTunes and not the Play Store. It also doesn't
> > seem to contain a fallback parameter like the iOS URL.
> 
> Alex, I confirmed with mhan that those are the correct URLs. Because it's
> not live yet, it's going to default to redirect to iOS. Once they publish
> the Google Play page on Tuesday, all will work fine.
> 
> So, it looks like we are all set. Thanks!

Ok, well I'll add a fallback URL and we can test on Tuesday to see if it works. We'll block merge / deploy until that time when it's live. Thanks
Flags: needinfo?(agibson)
(Assignee)

Comment 22

11 months ago
(In reply to Fabio Rios [:frios] from comment #21)
> Alex,
> 
> Mike made a minor change to the iOS URL, see updated below. 
> 
> iOS:
> https://app.adjust.com/
> b8s7qo?campaign=&adgroup=Focus&creative=iOS&fallback=https://itunes.apple.
> com//app/id1055677337?mt=8

Thanks, I'm going to assume there should be no double slash before //app in the fallback URL, and that the fallback URL should be properly URI encoded:

https://app.adjust.com/b8s7qo?campaign=&adgroup=Focus&creative=iOS&fallback=https%3A%2F%2Fitunes.apple.com%2Fapp%2Fid1055677337%3Fmt%3D8

If this is not the case please let me know.

Comment 23

11 months ago
Mike, I shared the URL you provided in comment #21. See comment 22 with Alex's question
Flags: needinfo?(mhan)

Updated

11 months ago
Duplicate of this bug: 1354609

Comment 25

11 months ago
Alex, I'm not sure how Adjust works, so if we don't hear back from Mike on this, I would suggest using what he supplied. Unless it's obviously wrong, or causing something to break.
Flags: needinfo?(agibson)
(Assignee)

Comment 26

11 months ago
(In reply to Fabio Rios [:frios] from comment #25)
> Alex, I'm not sure how Adjust works, so if we don't hear back from Mike on
> this, I would suggest using what he supplied. Unless it's obviously wrong,
> or causing something to break.

We still need the Android URL whenever that is live, so hopefully we'll hear back by then. The fallback URL seems to function correctly with my changes (try clicking the link in Comment 22).

If we don't hear back we can revert, but the URL should definitely be URI encoded either way.
Flags: needinfo?(agibson)

Comment 27

11 months ago
Alex, youre correct, theres an extra slash (previously we had a country code there)

Please use this url:

https://app.adjust.com/b8s7qo?campaign=&adgroup=Focus&creative=iOS&fallback=https://itunes.apple.com/app/id1055677337?mt=8
Flags: needinfo?(mhan)
(Assignee)

Comment 28

11 months ago
(In reply to mhan@mozilla.com from comment #27)
> Alex, youre correct, theres an extra slash (previously we had a country code
> there)
> 
> Please use this url:
> 
> https://app.adjust.com/
> b8s7qo?campaign=&adgroup=Focus&creative=iOS&fallback=https://itunes.apple.
> com/app/id1055677337?mt=8

Thanks - I notice there's also no value for `campaign=` in this URL. I'm guessing it should be `campaign=moz.org`?

We're against the clock here, so could you please review both URLs carefully and ensure they both have everything you need?

If you could paste both (fully formed) URLs here that would be great. I only have half a URL for Android thus far (it's still missing the fallback URL). Thanks
Flags: needinfo?(mhan)

Comment 30

11 months ago
(In reply to Alex Gibson [:agibson] from comment #28)
> (In reply to mhan@mozilla.com from comment #27)
> > Alex, youre correct, theres an extra slash (previously we had a country code
> > there)
> > 
> > Please use this url:
> > 
> > https://app.adjust.com/
> > b8s7qo?campaign=&adgroup=Focus&creative=iOS&fallback=https://itunes.apple.
> > com/app/id1055677337?mt=8
> 
> Thanks - I notice there's also no value for `campaign=` in this URL. I'm
> guessing it should be `campaign=moz.org`?
> 
> We're against the clock here, so could you please review both URLs carefully
> and ensure they both have everything you need?
> 
> If you could paste both (fully formed) URLs here that would be great. I only
> have half a URL for Android thus far (it's still missing the fallback URL).
> Thanks

Hey Alex, yeah it looks like that's missing the campaign=moz.org let's add that and push it. I tried the android one and it works fine with no fallback URL, so let's roll.

Thank you!

Comment 31

11 months ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/694193defae6d2fd671a804901d060d8cb87753b
[fix bug 1350170] Add Firefox Focus page

https://github.com/mozilla/bedrock/commit/4459643842eb3a80d01201d229bfd873460b5e5b
Merge pull request #4904 from alexgibson/bug-1350170-firefox-focus-page

[fix bug 1350170] Add Firefox Focus page

Updated

11 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED

Comment 33

11 months ago
For the android link, theres no fallback needed because android is set as the default platform.

Android link:
https://app.adjust.com/b8s7qo?campaign=moz.org&adgroup=Focus&creative=android

For iOS, please use this badge: (added campaign parameter)
https://app.adjust.com/b8s7qo?campaign=moz.org&adgroup=Focus&creative=iOS&fallback=https://itunes.apple.com/app/id1055677337?mt=8
(Assignee)

Comment 34

11 months ago
(In reply to mhan@mozilla.com from comment #33)
> For the android link, theres no fallback needed because android is set as
> the default platform.
> 
> Android link:
> https://app.adjust.com/b8s7qo?campaign=moz.org&adgroup=Focus&creative=android
> 
> For iOS, please use this badge: (added campaign parameter)
> https://app.adjust.com/b8s7qo?campaign=moz.
> org&adgroup=Focus&creative=iOS&fallback=https://itunes.apple.com/app/
> id1055677337?mt=8

These are essentially the same links as Comment 29 (aside from not being encoded fully). As discussed with Mhan on Slack, we're going to leave the fallback param in there for Android as it does not harm being there.

Comment 35

11 months ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/3456293291a0d3f8c5de1b3b7bfae3d220234676
[bug 1350170] Update values copy on /firefox/focus/ for l10n

https://github.com/mozilla/bedrock/commit/6a68ba4b872ba506a58125da5b773803887817a9
Merge pull request #4942 from alexgibson/bug-1350170-update-focus-copy-l10n

[bug 1350170] Update values copy on /firefox/focus/ for l10n
You need to log in before you can comment on or make changes to this bug.