Closed Bug 1350208 Opened 3 years ago Closed 2 years ago

Specify text color of selected profile item instead of inheriting from global autocomplete style

Categories

(Toolkit :: Form Manager, enhancement, P3)

53 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: ralin, Assigned: ralin)

References

Details

(Whiteboard: [form autofill:M1])

Attachments

(1 file)

Need to explicitly set text color for selected item after Bug 1348574 landed.
Hi Matt,

Since this is a one line change patch, would you mind to have a quick look to the patch if you get time? Here I just simply fix the color of primary label. Thanks :D
Comment on attachment 8850853 [details]
Bug 1350208 - Explicitly set default text color for profile item.

https://reviewboard.mozilla.org/r/123374/#review127044
Attachment #8850853 - Flags: review?(MattN+bmo) → review+
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/700fc0e95f64
Explicitly set default text color for profile item. r=MattN
https://hg.mozilla.org/mozilla-central/rev/700fc0e95f64
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Vance, could you please follow up on this bug as to the exact expected behavior is in regards to this bug?
Flags: needinfo?(vchen)
Steal the question from Vance :P

Since the dropdown is shared between multiple components, our stylesheets might be overwritten if we inherited the color from dropdown. In this bug, no new features or appearance change in this bug, instead we just explicitly set text color for our dropdown item in order to protect it from accidentally being broken by other components in the future. I'm afraid I couldn't give you the steps to verify this bug, perhaps, we can check whether the text color does conform with the spec or just ignore this bug. Thanks.
Flags: needinfo?(vchen)
You need to log in before you can comment on or make changes to this bug.