WebRTC certificates stored into indexed db don't survive a browser restart.

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
10 months ago
9 months ago

People

(Reporter: Tim Panton, Unassigned, NeedInfo)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170323004002

Steps to reproduce:

I create a new certificate with RTCPeerConnection.generateCertificate()
and store it in indexed db.
The certificate can be retrieved _only_ for the life of this browser. A browser restart leaves indexed db in an inconsistent state.
See :
https://pi.pe/iot/js/bug/putCert.html


Actual results:

After  a browser restart, pressing 'Get cert' results in an error in the console 
and no certificate retrieved.


Expected results:

The certificate should be retreived even after a browser reload.

Comment 1

10 months ago
WFM here on Linux, Nightly.
(Reporter)

Comment 2

10 months ago
(In reply to Paul Adenot (:padenot) from comment #1)
> WFM here on Linux, Nightly.

Yep - just tested on Mac Nightly - seems ok there too. 
Any idea what fixed it ? How can I help make sure it stays fixed ?

Comment 3

10 months ago
I Tried to reproduce your bug but I am unable to reproduce it ..
I opened the link https://pi.pe/iot/js/bug/putCert.html and pressed put cert
then reloaded the page and then pressed the get cert key and i got the output := Cert retrieved . Expires at 1522172938261
[Bugday-20170327]
(Reporter)

Comment 4

10 months ago
@surenthan14 - Thanks for testing it, that is the correct behaviour.
But did you quit the browser instance and restart it - or just reload the page? Which version did you test with?

For me the problem only shows up if the browser (<rv55) is completely shutdown between the put and get actions.

When I have an undisturbed couple of hours I'm going to do a set of regression tests to see when it got fixed and how!
Per Comment 2 this bug is works for me but in Comment 4 you are saying you are going to find a regression. Should we leave this issue open for the time being or close as works for me?
Flags: needinfo?(thp)
(Reporter)

Comment 6

10 months ago
Please leave this bug open for a few days - I'll give the regression a go at the weekend (the week has been crazy).
Flags: needinfo?(thp)
Is there any update from Comment 6?
Flags: needinfo?(thp)
Closing this issue due to lack of response from the reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.