Closed Bug 1350374 Opened 3 years ago Closed 2 years ago

Make sure image request proxies carry down the window id

Categories

(Core :: ImageLib, enhancement, P4)

enhancement

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox55 --- affected

People

(Reporter: mayhemer, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [gfx-noted])

Since there is (still..!) coalescing of image requests, I'm not sure if the outer content window id bubbles down to the http channel through the imgRequest class so that it can be used in the http transaction scheduler (bug 1312782).
Whiteboard: [gfx-noted]
Priority: -- → P4
Confirmed this works when an image is only present on a single page.  For the sake of this bug (prioritization), I believe this is sufficient for 99.9% cases.
This is known to work for a long time. WFM.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.