Drag&drop some HTTPS links in the download icon displays wrongly download as failed

VERIFIED FIXED in Firefox 54

Status

()

Firefox
Downloads Panel
VERIFIED FIXED
10 months ago
9 months ago

People

(Reporter: Loic, Assigned: dragana)

Tracking

({regression})

54 Branch
Firefox 55
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox52 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54+ verified, firefox55+ verified)

Details

(Whiteboard: [necko-active])

Attachments

(2 attachments)

(Reporter)

Description

10 months ago
Created attachment 8851053 [details]
failed-ddl-FF55.jpg

STR:

1) Open https://bugzilla.mozilla.org/
2) Wait for ~10 sec (it's empirical but I only found that to reproduce the issue consistently)
3) Drag&drop the link "Bugzilla@Mozilla" (upper left corner) in the download icon in the toolbar

Result: the download panel displays the yellow mark for "download failed" even if the file has been really downloaded (visible on the disk).

Regression range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5ae59bdcd2d4f9617d6663ab823b4a384fdd6204&tochange=08df0e07f0ba02a27e532b25a0d3415166a6bba1

Dragana Damjanovic — Bug 1343600 - add TLS handshake Start/Stop events. r=:valentin
(Reporter)

Updated

10 months ago
Blocks: 1343600
Has Regression Range: --- → yes
Has STR: --- → yes
status-firefox52: --- → unaffected
status-firefox53: --- → unaffected
status-firefox54: --- → affected
status-firefox55: --- → affected
tracking-firefox54: --- → ?
tracking-firefox55: --- → ?
Flags: needinfo?(dd.mozilla)
Keywords: regression
(Assignee)

Updated

10 months ago
Assignee: nobody → dd.mozilla
Status: NEW → ASSIGNED
Flags: needinfo?(dd.mozilla)
Whiteboard: [necko-active]
(Assignee)

Comment 1

10 months ago
Created attachment 8852060 [details] [diff] [review]
bug_1350388_v1.patch
Attachment #8852060 - Flags: review?(valentin.gosu)

Updated

10 months ago
Attachment #8852060 - Flags: review?(valentin.gosu) → review+
(Assignee)

Updated

10 months ago
Keywords: checkin-needed

Comment 2

10 months ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f129d307ce4b
NS_NET_STATUS_TLS_HANDSHAKE_STARTING/ENDED is not an error for nsWebBrowserPersist. r=valentin
Keywords: checkin-needed

Comment 3

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f129d307ce4b
Status: ASSIGNED → RESOLVED
Last Resolved: 10 months ago
status-firefox55: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Tracking 54/55+ for this regression.
tracking-firefox54: ? → +
tracking-firefox55: ? → +
(Assignee)

Comment 5

10 months ago
Comment on attachment 8852060 [details] [diff] [review]
bug_1350388_v1.patch

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1343600
[User impact if declined]: Downloads can be mark as failed, because nsWebBrowserPersist interpret new transport events  NS_NET_STATUS_TLS_HANDSHAKE_STARTING/ENDED as an error.
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: there are step to reproduce in comment #0
[List of other uplifts needed for the feature/fix]:none
[Is the change risky?]:none
[Why is the change risky/not risky?]: just add 2 additional transport status events to the list.
[String changes made/needed]:none
Attachment #8852060 - Flags: approval-mozilla-aurora?
status-firefox-esr52: --- → unaffected
Comment on attachment 8852060 [details] [diff] [review]
bug_1350388_v1.patch

regression fix for aurora54
Attachment #8852060 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 7

10 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/4a9388153442
status-firefox54: affected → fixed

Comment 8

10 months ago
I have successfully reproduced this bug on firefox nightly according to(2017-03-24)

Fixing bug is verified on Latest Developer Edition-- Build ID : (20170402004002),User Agent: Mozilla/5.0 (Windows NT 10.0; rv:54.0) Gecko/20100101 Firefox/54.0

Tested OS -- Windows10 32bit

[bugday-20170329]

Comment 9

10 months ago
The issue is no longer reproducible on Firefox 55.0a1 (2017-04-03)
OS:windows 7(32 bit)

[bugday-20170405]
[bugday-20170412]

The issue is no longer reproducible on Firefox Nightly 55.0a1.
Tests were performed under Windows 10x64.

Comment 11

9 months ago
[bugday-20170419]

Status: FIXED & VERIFIED.
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0

The issue is no longer reproducible on Firefox Aurora 
Tests were performed under Ubuntu 15.10 x64.
Flags: qe-verify+
I reproduced this issue with Fx 55.0a1 (24-03-2017) on Windows 7 x64.
I can confirm this issue is fixed I verified using Fx 55.0a1 (20170424030211) and Fx 54.0b1 on Windows 7 x64.

Cheers!
Status: RESOLVED → VERIFIED
status-firefox54: fixed → verified
status-firefox55: fixed → verified
Flags: qe-verify+

Comment 13

9 months ago
The issue is no longer reproducible on Firefox 52.0.2 (2017-04-03)
OS: macOS Sierra 10.12.3

[bugday-20170405]
You need to log in before you can comment on or make changes to this bug.