Message window hangs when fetching mail from IMAP server.

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Kirk Parsons, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2
BuildID:    2002040103

Frequently (about 30% of the time), the new message window hangs when I open up
an email by double clicking on the subject line. If I try, I can increase the
reproduceability by double clicking quickly on a message that's never been
opened.  When the bug occurs, a new message window is opened up, and it says
"Loading Document" in the status bar, but the window never renders the message
content, and it never finishes "loading".  

I think that this bug never occurs if the content of the email has already been
rendered in the preview pane. In other words, I think this bug is 100%
repeatable, if you're quick enough to double click on the subject line before it
has a chance to render the messages content in the preview pane.

 

Reproducible: Sometimes
Steps to Reproduce:
1.Double click quickly on a subject line in the email client.
2.An email message window comes up, but hangs, without rendering the message
content.


Actual Results:  1.Double click quickly on a subject line in the email client.
2.An email message window comes up, but hangs, without rendering the message
content.


Expected Results:  1.Double click quickly on a subject line in the email client.
2.An email message window comes up, with the message content rendered in the window.


I'm not sure that this is IMAP specific, but I would guess that it is. Also,
I've never filed a bug on the email client, and while I did make some effort to
search for this bug in existing reports, I was not able to find a bug that
matched.  

Since this bug is pretty heinous (in terms of irritation upon regular IMAP
users), I would have guessed that somebody's filed it already (unless there's
something very specific about my configuration that makes it occur).  It
certainly would be nice to get this fixed.

Comment 1

16 years ago
I tried hard - no success in reproducing.
(Reporter)

Comment 2

16 years ago
I might have screwed up in submitting this one.  I may have made this repeat
based on a February build, when I thought I was testing from yesterday's build.
 I'll do some more testing today (being more careful about the version), and see
if I can get it to repeat.

Comment 3

16 years ago
Karen, is it your area?
QA Contact: olgam → huang
(Reporter)

Comment 4

16 years ago
I've spent a couple of days using build 2002020406, and I can indead repeat this
bug.  It does seem to be more difficult to make recur, but it does happen at
least a few times a day.  As originally described, it is most likely to repeat
on an email that I have never read before.

Comment 5

16 years ago
20020913 trunk build on Win2K

Resolve this bug marking WFM.
Please reopen it if happening again.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 6

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.