Bugzilla scheduled maintenance page has 404 for mozilla log

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Alex_Gaynor, Assigned: danielh)

Tracking

Details

(Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/4489])

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.110 Safari/537.36

Steps to reproduce:

Browse to https://hardhat.cdn.mozilla.net/en-US/bugzilla.html (or be redirected there while Bugzilla is down for maintaince)


Actual results:

Logo image is a 404


Expected results:

It should load :-)
(Reporter)

Comment 1

a year ago
Pull request resolving this here: https://github.com/mozilla/hardhat/pull/3
:limed, this endpoint is an S3 bucket somewhere in our account, right?
Assignee: infra → server-ops-webops
Component: Infrastructure: Other → WebOps: Other
Flags: needinfo?(limed)
QA Contact: cshields → smani

Updated

a year ago
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/4489]

Comment 3

a year ago
host hardhat.cdn.mozilla.net
hardhat.cdn.mozilla.net is an alias for d3kg5zwk0p5168.cloudfront.net

This is on the it-cdn aws account
Flags: needinfo?(limed)

Updated

a year ago
Assignee: server-ops-webops → dhartnell
(Assignee)

Comment 4

a year ago
Hey Alex,

This should be resolved. If you need anything else from me, feel free to ask.

After merging your pull request, I realized that there is no pipeline to connect the GitHub repository to this specific S3 bucket (someone can correct me if I'm wrong). It looks like the content in the S3 bucket has deviated from what's on GitHub over time. So, I downloaded the bugzilla.html file, edited it and then re-uploaded it to the bucket. Instead of using the path that you provided, I matched the path that: https://hardhat.cdn.mozilla.net/en-US/outages.html was using. This is: "/img/mozilla-logo.png".

I'm going to create a bug to propose that we build out that pipeline. A simple solution could utilize Travis CI to run some tests and then deploy to S3:

https://docs.travis-ci.com/user/deployment/s3/

Before doing that, we should diff the S3 bucket and GitHub repository to get them in sync and then try to ensure that future changes are done in GitHub.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.