Closed Bug 1350525 Opened 3 years ago Closed 3 years ago

Cookies doesn't show up for urls with port

Categories

(DevTools :: Storage Inspector, defect, P2)

53 Branch
defect

Tracking

(firefox52 unaffected, firefox-esr52 unaffected, firefox53 wontfix, firefox54 fixed, firefox55 fixed)

RESOLVED FIXED
Firefox 55
Tracking Status
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- wontfix
firefox54 --- fixed
firefox55 --- fixed

People

(Reporter: dehghani.m.c, Assigned: miker)

References

Details

(Keywords: regression, regressionwindow-wanted, Whiteboard: [todo-mr])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170323090023

Steps to reproduce:

Open up (for ex.) 192.168.1.10:7070, also Developer console, storage tab.


Actual results:

The cookies list is empty (I tired with FF v53x. and v54.x)


Expected results:

Cookies must be available for urls with ports.
Component: Untriaged → Developer Tools: Storage Inspector
I had to install Firefox 52.0.1 (stable version), this issue doesn't exits in 52.0.1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [todo-mr]
Mike, can you help find someone to look into this ? Thanks. 
Too late to fix for 53 though, as we are heading into release next week.
Flags: needinfo?(mratcliffe)
Yes, I will get onto it right away.
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
Flags: needinfo?(mratcliffe)
Priority: -- → P2
It appears that cookies are different than other storage types in that they do not provide isolation by port.

This means that we are free to strip the port from the hostname for cookies in the storage inspector.
Comment on attachment 8857045 [details]
Bug 1350525 - Storage Inspector should trim port from hosts for cookies

https://reviewboard.mozilla.org/r/128938/#review131888
Attachment #8857045 - Flags: review?(pbrosset) → review+
I think the try failures were a bad try run (bad build) but rebasing and retriggering just in case.
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/67b5c2f3011b
Storage Inspector should trim port from hosts for cookies r=pbro
https://hg.mozilla.org/mozilla-central/rev/67b5c2f3011b
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Please request Aurora approval on this when you get a chance.
Flags: needinfo?(mratcliffe)
Comment on attachment 8857045 [details]
Bug 1350525 - Storage Inspector should trim port from hosts for cookies

Approval Request Comment
[Feature/Bug causing the regression]: Never worked
[User impact if declined]: They will not be able to inspect cookies when a URL contains a port number.
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: Just Aurora
[Is the change risky?]: No
[Why is the change risky/not risky?]: It is a very simple change.
[String changes made/needed]: -
Flags: needinfo?(mratcliffe)
Attachment #8857045 - Flags: approval-mozilla-aurora?
Comment on attachment 8857045 [details]
Bug 1350525 - Storage Inspector should trim port from hosts for cookies

Fix a cookie issue for urls with port. Aurora54+.
Attachment #8857045 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 1355489
(In reply to Mehdi from comment #16)
> Hey guys,
> 
> FF 53 have this bug, great!
> I think it's very important bug, specially for Developers, why you release
> new version including bugs like this? I don't understand !! now I have no
> option but Chrome, is that what you want? are you planing to loose FF's
> users?

Please read bugzilla's etiquette and contributor guidelines here https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
This comment is violating at least 2 bullet points from the etiquette.
Duplicate of this bug: 1360634
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.