Add a button to display the Table of contents of the page

RESOLVED DUPLICATE of bug 670928

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 670928
2 years ago
2 years ago

People

(Reporter: curieux.public, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170316213829

Steps to reproduce:

Suggestion:
A button that will display/hide a column on the left of the page, containing the Table of contents of this page.

That seems to be a basic functionality that will ease reading the pages.

I know some add-ons pretend doing that but they do not work correctly or they impose installing other extensions (as GreaseMonkey).
As I say, this is a very basic functionality, something as primitive as displaying informations about the page, maybe even more. So it should be integrated into FireFox.

Comment 1

2 years ago
Dupe to bug 670928?
(Reporter)

Comment 2

2 years ago
(In reply to YF (Yang) from comment #1)
> Dupe to bug 670928?

The functionality I describe is for all public.

You can see an example here: https://addons.mozilla.org/en-US/firefox/addon/table-of-contents/
Except:
1. This add-on is not compatible with the recent versions of FireFox.
2. I believe such a basic functionality should be part of FireFox itself.

The vast majority of web pages does not present a table of contents, and in fact web pages do not have simple, standard way of doing that.
But readers need to understand at first sight what a page contain. For centuries, books have Table of contents, it is for a good reason.

Comment 3

2 years ago
Browser: 53.0b6
OS: win 10 - 64 bit
It is working in new version of Firefox
[bugday-20170327]

Updated

2 years ago
Severity: normal → enhancement

Updated

2 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true

Comment 4

2 years ago
This is effectively a dupe of bug 670928, yes. If and how we should expose navigational structure of pages into Firefox is discussed there. The exact implementation in the add-on is likely not usable as-is for integration into Firefox, so I don't think that justifies keeping this issue open separately. Marking as a duplicate.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 670928
(Reporter)

Comment 5

2 years ago
Well, as far as I read, the bug 670928 is (or was) about the Disability Access component, while the enhancement I propose is for all public. The bug 670928 seems to be much about ARIA landmarks and role declarations, more than simple header/section elements.
If the thread of bug 670928 is now about a table of contents for anyone, it may be renamed, or the discussion should be moved to a new thread, no ?

By the way, the bug 670928 is 6 years old now. Ouch !

As a side note, a few days ago, Microsoft has added a table of contents to Edge. See https://blogs.windows.com/windowsexperience/2017/05/04/announcing-windows-10-insider-preview-build-16188-pc-build-15210-mobile/
It seems to be easy to use, and useful to visual impaired people too (I guess the screen readers can read this tree with ease, did not try for now).

I would like to have the adequate competency in order to help making this Table of contents for everyone (including visually impaired using landmarks and roles), but unfortunately I do not. Then I encourage goodwill. Good luck !
You need to log in before you can comment on or make changes to this bug.