Search widget doesn't show search results on enter

RESOLVED DUPLICATE of bug 1316080

Status

()

Firefox for Android
Search Activity
RESOLVED DUPLICATE of bug 1316080
10 months ago
9 months ago

People

(Reporter: Will Levine, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170317213149

Steps to reproduce:

1) Put the firefox search widget on your homescreen.
2) Hit search on the widget.
3) Type in something
4) Hit the search button (icon of magnifying glass) on keyboard to initiate the search.


Actual results:

The search results don't show. The keyboard disappears from the screen, but the search suggestions stay on the screen. If you want to actually see the search results you have to tap the search box at the top of the screen again to reactivate the keyboard and then hit enter (magnifying glass icon) again. Then the search results finally show up.


Expected results:

Search results show up the first time.
Component: General → Search Activity

Comment 1

10 months ago
Hello, thanks for your report. 
I could not reproduce the issue on the latest Firefox 52 or Nightly 55 builds, with Huawei Honor 8 (Android 6.0) & LG G4 (Android 5.1).
Could you please give more details about what device you were using? Also, please try to reproduce the issue again on the latest Nightly build: http://archive.mozilla.org/pub/mobile/nightly/2017/03/ and let us know if you still encounter the same problem.
Flags: needinfo?(wlevine)
(Reporter)

Comment 2

10 months ago
After further testing, I've noticed that the bug only occurs while using the Swype keyboard and not the default keyboard app. Is there an easy way for me test older version of Firefox, without losing my current profile. I'd like to see if this bug appeared due to a recent change in Firefox, or a change in the keyboard app.

By the way, I'm using a Sony Xperia X Compact with Android 7.0. The bug still appears in the nightly builds.
Flags: needinfo?(wlevine)
Hello,

 You can get older versions of Firefox from here: http://archive.mozilla.org/pub/mobile/ . You will need to download and install the .apk file on your phone. To not lose your profile or make any changes to your browser you can download a Beta, Aurora or Nightly build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1316080
You need to log in before you can comment on or make changes to this bug.