Regression on 2016-09-08: WARNING: 0:1: extension 'GL_ARB_gpu_shader5' is not supported

RESOLVED DUPLICATE of bug 1310741

Status

()

Core
Canvas: WebGL
RESOLVED DUPLICATE of bug 1310741
a year ago
a year ago

People

(Reporter: Jukka Jylänki, Unassigned)

Tracking

51 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

197.45 KB, application/zip
Details
(Reporter)

Description

a year ago
Created attachment 8851340 [details]
float_tex.zip

STR: Uncompress zip and run float_tex.html

Observed:

Page prints

   Shader info: WARNING: 0:1: extension 'GL_ARB_gpu_shader5' is not supported

The shaders on the page are https://github.com/kripken/emscripten/blob/master/tests/float_tex.cpp#L11

Using mozregression to bisect, this broke on 2016-09-08, with mozregression pointing to

 8:20.03 INFO: Downloading build from: https://queue.taskcluster.net/v1/task/WmCYltWqSOmJwhvexCZnog/runs/0/artifacts/public%2Fbuild%2Ffirefox-51.0a1.en-US.mac.dmg
===== Downloaded 100% =====
 8:31.48 INFO: Running mozilla-central build built on 2016-09-08 23:56:30.060000, revision e6e733f5
 8:57.27 INFO: Launching /private/var/folders/vh/hdrmw_ts7tv65hzh3n88cp3h0000gn/T/tmpIaI6JS/Nightly.app/Contents/MacOS/firefox
 8:57.27 INFO: Application command: /private/var/folders/vh/hdrmw_ts7tv65hzh3n88cp3h0000gn/T/tmpIaI6JS/Nightly.app/Contents/MacOS/firefox -foreground -profile /var/folders/vh/hdrmw_ts7tv65hzh3n88cp3h0000gn/T/tmpcuNSVy.mozrunner
 8:57.28 INFO: application_buildid: 20160908151120
 8:57.28 INFO: application_changeset: e6e733f522a584cddd27ec255d801983a9f9051e
 8:57.28 INFO: application_name: Firefox
 8:57.28 INFO: application_repository: https://hg.mozilla.org/mozilla-central
 8:57.28 INFO: application_version: 51.0a1
Was this inbound build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', 'back' or 'exit' and press Enter): good
 9:05.02 INFO: Narrowed inbound regression window from [938ce16b, d4060d4f] (5 revisions) to [e6e733f5, d4060d4f] (3 revisions) (~1 steps left)
 9:05.02 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e6e733f522a584cddd27ec255d801983a9f9051e&tochange=d4060d4f4f6771608e0c4ee6fc62e430b6f244c0

 9:05.02 INFO: Downloading build from: https://queue.taskcluster.net/v1/task/KKQ3fEwCRkalfUWP1rxE5A/runs/0/artifacts/public%2Fbuild%2Ffirefox-51.0a1.en-US.mac.dmg
===== Downloaded 100% =====
 9:16.19 INFO: Running mozilla-central build built on 2016-09-09 00:20:22.165000, revision 176aff98
 9:41.04 INFO: Launching /private/var/folders/vh/hdrmw_ts7tv65hzh3n88cp3h0000gn/T/tmp7xfAd3/Nightly.app/Contents/MacOS/firefox
 9:41.05 INFO: Application command: /private/var/folders/vh/hdrmw_ts7tv65hzh3n88cp3h0000gn/T/tmp7xfAd3/Nightly.app/Contents/MacOS/firefox -foreground -profile /var/folders/vh/hdrmw_ts7tv65hzh3n88cp3h0000gn/T/tmpVfDKzB.mozrunner
 9:41.05 INFO: application_buildid: 20160908152324
 9:41.05 INFO: application_changeset: 176aff980979bf588baed78c2824571a6a7f2b96
 9:41.05 INFO: application_name: Firefox
 9:41.05 INFO: application_repository: https://hg.mozilla.org/mozilla-central
 9:41.05 INFO: application_version: 51.0a1
Was this inbound build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', 'back' or 'exit' and press Enter): bad
 9:48.57 INFO: Narrowed inbound regression window from [e6e733f5, d4060d4f] (3 revisions) to [e6e733f5, 176aff98] (2 revisions) (~1 steps left)
 9:48.57 INFO: Oh noes, no (more) inbound revisions :(
 9:48.57 INFO: Last good revision: e6e733f522a584cddd27ec255d801983a9f9051e
 9:48.57 INFO: First bad revision: 176aff980979bf588baed78c2824571a6a7f2b96
 9:48.57 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e6e733f522a584cddd27ec255d801983a9f9051e&tochange=176aff980979bf588baed78c2824571a6a7f2b96
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1310741
You need to log in before you can comment on or make changes to this bug.