ctrl-w (close tab) should not quit mozilla if it is the last one

VERIFIED DUPLICATE of bug 39057

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 39057
16 years ago
13 years ago

People

(Reporter: Chung-Kie Tung, Assigned: Matti)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Hi,

This is a suggestion more than a bug.
Whenever user close a tab with ctrl-w, there are 3 situations:

1. more than one tabs in current window
   mozilla response => close the current tab
2. only one tab on current window
   mozilla response => close the current window
3. only one tab on current winow and current window is the last one
   mozilla response => close the current window and quit mozilla

Since mozilla takes times to start up, user may not want to quit mozilla so
often. Is it possible to have a confirm window if mozilla wants to quit
completely? Or we can make a option in user preference like below:

action on close last window 
1.confirm quit
2.quit directly
3.no quit

This may save usr a lot of time in restarting the mozilla in case they press the
ctrl-w on the last mozilla window.

Thanks.
(Assignee)

Comment 1

16 years ago
we have bug 108973 (add a dialog if you close a window with many open tabs).

and we have bug 52821 and also bug 39057

BTW: Please use the severity field and choose enhancement for your next suggestion.


*** This bug has been marked as a duplicate of 39057 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
I would have marked it as dup of bug 108973, but it doesn't really matter.
vrfy.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.