Closed Bug 1350822 Opened 3 years ago Closed 2 years ago

Remove --with-android-gnu-compiler-version from configure

Categories

(Firefox Build System :: Android Studio and Gradle Integration, enhancement)

54 Branch
Unspecified
Android
enhancement
Not set

Tracking

(firefox57 fixed)

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: m_kato, Assigned: m_kato)

References

Details

Attachments

(1 file)

By https://groups.google.com/forum/#!topic/mozilla.dev.platform/QgxoSzTcp1M, we don't support 4.7 and 4.8.  But --with-android-gnu-compiler-version can set 4.7 or 4.8.

And Android's gcc only supports 4.9 and they won't support 5.0+.  So we can remove --with-android-gnu-compiler-version option.
Comment on attachment 8910231 [details]
Bug 1350822 - Remove --with-android-gnu-compiler-version.

https://reviewboard.mozilla.org/r/181714/#review187420
Attachment #8910231 - Flags: review?(mh+mozilla) → review+
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/fc5b1c09a348
Remove --with-android-gnu-compiler-version. r=glandium
https://hg.mozilla.org/mozilla-central/rev/fc5b1c09a348
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Assignee: nobody → m_kato
Product: Firefox for Android → Firefox Build System
Target Milestone: Firefox 57 → mozilla57
You need to log in before you can comment on or make changes to this bug.