Status

defect
REOPENED
18 years ago
10 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

({regression})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [See comment 35] [ADT2 RTM],custrtm-)

Attachments

(1 attachment, 2 obsolete attachments)

Reporter

Description

18 years ago
In Classic:

In Mail Compose, the two dropdowns in the toolbar are truncated...you can't 
read them.

In both Modern and Classic:

One of the dropdowns in the Mail & Newsgroups > Message Display pref panel is 
truncated.
Reporter

Comment 1

18 years ago
This is a regression that has to be fixed. The fix should be simple/trivial.
Keywords: nsbeta1, regression

Comment 2

18 years ago
see also bug 135229

Comment 3

17 years ago
approving nomination. adding [adt2] to indicate breadth of exposure of this bug.
It renders the initial text unusable as a menu label by truncating the text
inappropriately. Easy fix, small risk. 
Keywords: nsbeta1nsbeta1+
Whiteboard: [ADT2]
Charlie, I think this is the bug you were seeing in Composer.  You did verify
that this wasn't caused by my patch for bug 131481, right?

Comment 5

17 years ago
Brian: yes, I did, but it deserves another confirmation. I'll test again soon.

Comment 6

17 years ago
Posted patch patch suggestions (obsolete) — Splinter Review
Just some suggested changes. It seems that the padding-left is excessive for 
Modern theme, so these changes really helped in many menulists.
Classic doesn't have these left padding amounts, and still seeems to show 
cropped strings.
I still suspect some basic flaw in menulist width calculations -- maybe we are
not
taking into account the width of the graphic on the right used to open the 
menupopup?

Comment 7

17 years ago
*** Bug 138307 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
My comments from bug 138307:
The default behavior for calculating the preferred width of a menulist should be 
to fit the longest string in the child menupopup->menuitems without cropping.
The most noticeable case is in Composer, including Message Composer:
The Paragraph Style menulist on the formating toolbar should show "Body Text", 
but not it shows "Body T...".
There are many more examples in Composer dialogs are being cropped, e.g.,
1. Click on the Table button and insert a default table. 
2. Dbl click in a cell to bring up Table Properties dialog
3. In the "Size" group, change the "Height" menulist from "pixels" to "% of
table" the later string will be cropped.
Change "Vertical" alignment menulist from "Top" to "Bottom" and latter will be 
cropped. 
In the Image dialog (click on Image toolbar button):
1. Change to the "Appearance" tab. The alignment menulist shows "At the..."
when it should be "At the Bottom"

I tested the 1.0 branch build and it does NOT show the cropped "Body Text" in 
pargraph menulist on Composer toolbar, but it does show the other examples 
of cropping text in various dialog menulists.

Comment 9

17 years ago
As noted in comment #8, this bug does not appear for the Composer toolbar 
paragraph style menulist on the branch. I applied the patch that fixed bug 131481
to the branch and it did NOT cause the menulist cropping to occur, so that fix
is not part of this problem.

Comment 10

17 years ago
adding 14px padding to menulist menuitems (the amount of padding that used to
be on menu accelerators which were removed from menulists)
Comment on attachment 81542 [details] [diff] [review]
patch
[Checkin: Comment 24 & 34]

good catch.  r=bryner.
Attachment #81542 - Flags: review+

Comment 12

17 years ago
Posted patch additional suggestion (obsolete) — Splinter Review
I agree that fixing the right padding on menu items is very good.
Could you also still include this change from my previous suggested patch?
The 8 pixel padding on the left of menulist in modern still seems like wasted 
space to me!
Attachment #80716 - Attachment is obsolete: true

Comment 13

17 years ago
Comment on attachment 81542 [details] [diff] [review]
patch
[Checkin: Comment 24 & 34]

sr=hewitt
Attachment #81542 - Flags: superreview+

Comment 14

17 years ago
let's keep the 8px padding on the left for now because it looks nicer. but if 
that's turns out to be a problem with cropping (it should be okay now though) 
we can reduce it later.

Comment 15

17 years ago
I don't think it *does* look nicer! Classic doesn't have it. It looks like wasted
space to me!
Jennifer, Lori, Blake: Any opinion?

Comment 16

17 years ago
just asked lori, she said to use the larger padding
Reporter

Comment 17

17 years ago
So are we really going to ship with this?  This really needs to get into the
beta, it's embarrassing.
Reporter

Comment 18

17 years ago
*** Bug 142017 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
Since this probably won't be in the beta, adding RTM to be sure it's checked in
for final release. Could someone please assign an appropriate milestone?
Whiteboard: [ADT2] → [ADT2 RTM]

Comment 20

17 years ago
*** Bug 143789 has been marked as a duplicate of this bug. ***

Comment 21

17 years ago
Getting dups on this already for beta build. This is important to fix for RTM
Keywords: adt1.0.0

Comment 22

17 years ago
Sorry, this isn't as critical as bug 131481 (and dup bug 143789), but it is 
a simple and safe UI fix that is very important "polish" and should be fixed for 
RTM.

Comment 23

17 years ago
Comment on attachment 81785 [details] [diff] [review]
additional suggestion

Decision was made to not use  this
Attachment #81785 - Attachment is obsolete: true

Comment 24

17 years ago
fixed in trunk
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED

Comment 25

17 years ago
Verified on windows 2000 (trunk build: 2002-05-21-08-TRUNK)
Status: RESOLVED → VERIFIED

Comment 26

17 years ago
Adding custrtm-; no impact on customization.
Was this a Windows only issue, as it says OS: Windows XP, or is this change
needed cross platform?
Keywords: adt1.0.0adt1.0.1

Updated

17 years ago
Whiteboard: [ADT2 RTM] → [ADT2 RTM],custrtm-

Comment 28

17 years ago
This is an XP problem.
Hardware: PC → All

Updated

17 years ago
OS: Windows XP → All

Comment 29

17 years ago
*** Bug 148445 has been marked as a duplicate of this bug. ***

Comment 30

17 years ago
this is very very important for localized build. What happen is currently in
modern theme if the selected one is the longest menu item, the text will be
truncated. But in Japanese and Chinese localization, most of the items will be
translated into the same length (2 or 4 chinese/japanese characters). so we will
always only display one chinese (the first one) characters with "..." in it. And
since it only show one characters (it should show two), no body can really tell
what it mean for MOST of the drop down in the pref window or other ui.

please take this for m1.0 and approve it for adt
Keywords: intl, mozilla1.0.1

Updated

17 years ago
Blocks: 141008

Comment 31

17 years ago
ADT1.0.1+, okay to checkin to the branch once you have drivers' approval.
Keywords: adt1.0.1adt1.0.1+

Comment 32

17 years ago
Please get drivers approval for this fix.

Updated

17 years ago
Attachment #81542 - Flags: approval+

Comment 33

17 years ago
please checkin to the 1.0.1 branch. once there remove the "mozilla1.0.1+"
keyword and add the "fixed1.0.1" keyword.

Comment 34

17 years ago
checked into branch a few days ago

Updated

17 years ago
Blocks: 146292
No longer blocks: 141008
Reporter

Comment 35

17 years ago
An okay workaround for rtm, but this bug is not fixed, just worked around.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 36

17 years ago
*** Bug 187609 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Depends on: 203722
Product: Core → SeaMonkey
QA Contact: pmac → themes
Assignee: shliang → nobody
QA Contact: themes → themes
Attachment #81542 - Attachment description: patch → patch [Checkin: Comment 24]
Attachment #81542 - Attachment description: patch [Checkin: Comment 24] → patch [Checkin: Comment 24 & 34]
Whiteboard: [ADT2 RTM],custrtm- → [See comment 35] [ADT2 RTM],custrtm-
You need to log in before you can comment on or make changes to this bug.