Closed Bug 1351456 Opened 3 years ago Closed 3 years ago

Intermittent dom/media/webaudio/test/test_nodeCreationDocumentGone.html | Test timed out.

Categories

(Core :: Web Audio, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- fixed
firefox54 --- fixed
firefox55 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: padenot)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed])

Attachments

(1 file)

Rank: 35
Priority: -- → P3
This test was just added in bug 1343550.

Failures affect all desktop platforms, but osx/debug/e10s might be the most frequent. 

:padenot -- Can you make this test more reliable?
Blocks: 1343550
Flags: needinfo?(padenot)
Whiteboard: [stockwell needswork]
Pushed by paul@paul.cx:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7cb01f9b0aed
Add some instrumentation to try to understand a test timeout. irc-r=jesup
Assignee: nobody → padenot
Flags: needinfo?(padenot)
https://hg.mozilla.org/mozilla-central/rev/7cb01f9b0aed
https://hg.mozilla.org/mozilla-central/rev/1ef7a511aefd
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla55 → ---
Duplicate of this bug: 1352658
Comment on attachment 8853924 [details]
Bug 1351456 - Don't assume that window.load will be called after the pref has been flipped.

https://reviewboard.mozilla.org/r/125948/#review128470

Some nits inline. But the bigger question I have is what this is testing? There's no failure path other than crashing?

Also,
Does pushing the pref guarantee to resolve *after* onload?

::: dom/media/webaudio/test/test_nodeCreationDocumentGone.html:26
(Diff revision 1)
>    var sub = encodeURI("data:text/html,<!DOCTYPE html>\n"+
>                        "<html><script>"+
>                        "var context = new AudioContext();"+
>                        "setTimeout(function(){window.close();},1000);\x3C/script></html>");
> -  window.onload = function(){
>      info("after onload");

This is now wrong.

::: dom/media/webaudio/test/test_nodeCreationDocumentGone.html:26
(Diff revision 1)
>      info("after onload");
>      var a = window.open(sub);
>      info("after open: " + a);
>      a.onbeforeunload = function(){
>        setTimeout(function(){
>          try {
>            info("before sp");
>            a.context.createScriptProcessor(512, 1, 1);
>            info("after sp");
>          } catch(e) {
>            ok (true,"got exception");
>          }
>          setTimeout(function() {
>            info("finish");
>            ok (true,"no crash");
>            SimpleTest.finish();
>          }, 0);
>        }, 0);
> -    };
> +    }
> -  };
> -});
> +  });

Indentation is 4, should be 2.
Attachment #8853924 - Flags: review?(pehrson)
Comment on attachment 8853924 [details]
Bug 1351456 - Don't assume that window.load will be called after the pref has been flipped.

https://reviewboard.mozilla.org/r/125948/#review129330
Attachment #8853924 - Flags: review?(pehrson) → review+
Pushed by paul@paul.cx:
https://hg.mozilla.org/integration/autoland/rev/e472bf9c3644
Don't assume that window.load will be called after the pref has been flipped. r=pehrsons
https://hg.mozilla.org/mozilla-central/rev/e472bf9c3644
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
https://hg.mozilla.org/releases/mozilla-aurora/rev/eb0d361dc73c
Flags: in-testsuite+
Whiteboard: [stockwell needswork] → [stockwell fixed]
You need to log in before you can comment on or make changes to this bug.