Do not remove XUL extensions, they are the main reason for using firefox for many

VERIFIED INVALID

Status

()

VERIFIED INVALID
a year ago
a year ago

People

(Reporter: u590800, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.21 Safari/537.36

Steps to reproduce:

Used firefox for its wealth of extensions.


Actual results:

Mozilla unilaterally decided to kill the reason why I and many others choose to use firefox and will lose some of its long time and dedicated user base along with many extension developers.

Refer to this HN discussion for example: https://news.ycombinator.com/item?id=13503107


Expected results:

Firefox ought to have retained compatibility with the existing extensions, or at least provided feature parity between current extension API and the new one.

Mozilla should provide a way for users to give feedback and listen to what they have to say.
(Reporter)

Comment 1

a year ago
Additional references to what extensions seem to matter most, **** off extensions developer and discussion on the possible future of said extension when it's not already announced as dead:

https://www.reddit.com/r/firefox/comments/3m0lis/data_from_the_what_webextensions_are_musthaves/
http://www.downthemall.net/re-downthemall-and-webextensions-or-why-why-i-am-done-with-mozilla/
http://fasezero.com/lastnotice.html
http://tabmixplus.org/forum/viewtopic.php?f=1&t=19282
http://getfirebug.com/
(Reporter)

Comment 2

a year ago
Also this mozillazine thread: http://forums.mozillazine.org/viewtopic.php?f=7&t=3025513
bugs are not for discussions, we have groups for that e.g. https://groups.google.com/forum/#!forum/mozilla.dev.platform
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

a year ago
The disabled user voice api ideas vote:
https://webextensions.uservoice.com/forums/315663-webextension-api-ideas
(Reporter)

Comment 5

a year ago
This is not a discussion, this is a feature request or even more a do not remove the feature many people rely on request.
Quite a valid request when you follow the discussions.

Sorry I care about privacy, both mine and others, and internet, so I won't register a google account or support anything supporting google (or any other giant working at killing internet see the death of transit at apnic for details).
(In reply to u590800 from comment #5)
> Sorry I care about privacy, both mine and others, and internet, so I won't
> register a google account or support anything supporting google (or any
> other giant working at killing internet see the death of transit at apnic
> for details).

FYI:
https://bugzilla.mozilla.org/show_bug.cgi?id=1345661#c126
> Since several people have emailed me about this, I'd like to clarify:
> participating in our mailing lists like dev-platform does *not* require a
> Google account.
> 
> You can subscribe with any email address here:
> https://lists.mozilla.org/listinfo/dev-platform
> You can post to the list as instructed on that page.
> You can view the list archives (without being logged into a Google account)
> here: http://groups.google.com/group/mozilla.dev.platform

In addition, you don't even have to access google.com domains to view the archives:
https://lists.mozilla.org/pipermail/dev-platform/
Comment hidden (admin-reviewed)

Comment 8

a year ago
Hi, everyone. I'm restricting this bug to editbugs-only, for a number of reasons.

The decision to end support for XUL was made with great care by people invested in the success of Firefox and the Web, people with a deep understanding of the challenges and hard tradeoffs involved.

Those tradeoffs have been real,  often difficult; we knew going from the beginning that this would be the case. Still: we are confident that it is the right decision, both for Firefox, the addon developer community, and ultimately the Web.  A lot of engineering has gone into making it happen. Even if it were not far too late to start unwinding all the work that has gone into this transition effort, we would still stand by this decision.

Thank you.
Restrict Comments: true
You need to log in before you can comment on or make changes to this bug.