Closed Bug 13517 Opened 20 years ago Closed 20 years ago

Prompted for database password when not needed

Categories

(SeaMonkey :: Passwords & Permissions, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: paulmac, Assigned: morse)

References

()

Details

I have a signon saved at
http://bugzilla.mozilla.org/enter_bug.cgi?product=Browser

However, I am prompted for my database password whenever I simply go to
http://bugzilla.mozilla.org

To reproduce:

1. Go to http://bugzilla.mozilla.org/enter_bug.cgi?product=Browser
2. Enter a signon and choose to save it
3. Quit and relaunch
4. Go to http://bugzilla.mozilla.org

Results: You will be asked to enter your database password, even though there is
no reason to do so.

Expected Results: You should not be asked until you actually need it.

All platforms, 9/9 builds

It seems to be okay at scopus/bugsplat (though I can't login there/separate
bug). I don't know what is different.
Status: NEW → ASSIGNED
Target Milestone: M11
What's different is that bugzilla has a form on the non-password website whereas
bugsplat didn't.  Of course you couldn't care less, but that upset the
single-signon heuristic.

I have a fix ready to be checked in just as soon as the tree opens.
actually, I wondered if that was the difference :-)
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
OK, the tree opened -- the fix is now checked in.
Status: RESOLVED → VERIFIED
verified, 9/13
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.