Not uploading symbols for Linux beta builds

RESOLVED FIXED

Status

Release Engineering
Release Automation
P1
blocker
RESOLVED FIXED
10 months ago
10 months ago

People

(Reporter: ted, Assigned: aki)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

MozReview Requests

Submitter Diff Changes Open Issues Last Updated
Loading...
Error loading review requests:

Attachments

(2 attachments)

(Reporter)

Description

10 months ago
glandium noticed something was strange in bug 1350721, I'll just paste my comment from there:
(In reply to Mike Hommey [:glandium] from comment #6)
> Looks like something is going wrong with symbols for beta builds, since the
> modules list in that last crash report *does* have the valid fileid for
> libxul.so in that build of 53.0b6 build.

Looking at:
https://hg.mozilla.org/releases/mozilla-beta/rev/FIREFOX_53_0b6_BUILD1

This is the 53.0b6 Linux64 build:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&revision=62467dd7218f&selectedJob=85961966

It sets `MOZ_AUTOMATION_UPLOAD_SYMBOLS=0`, since it's building in taskcluster, but I don't see that a symbol upload job actually ran for it.

Looking at a Nightly build on central:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&selectedJob=87273351

There's a symbol upload job to go with it:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&selectedJob=87288500

This seems bad!

Since these builds are done in taskcluster they don't upload their symbols to Socorro, there's supposed to be a separate symbol upload task. That doesn't seem to be wired up for beta, although it clearly is for nightly.
(Reporter)

Updated

10 months ago
tracking-firefox53: --- → ?
(Assignee)

Updated

10 months ago
Assignee: nobody → aki
Priority: -- → P1
Comment hidden (mozreview-request)
(Assignee)

Comment 2

10 months ago
Created attachment 8852608 [details]
symbols-graph-diff

This is the diff in target-graphs between pre-patch and post-patch.

Comment 3

10 months ago
mozreview-review
Comment on attachment 8852607 [details]
bug 1351774 - add upload-symbols jobs to beta.  a=release

https://reviewboard.mozilla.org/r/124792/#review127332
Attachment #8852607 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 5

10 months ago
I see symbols tasks in https://tools.taskcluster.net/task-group-inspector/#/WQQ4GmTDQb-_BO7F836-Yw?_k=brkwco (latest m-b on-push graph).

Landed on inbound, aurora, beta. This should ride the trains. -> RESO FIXED
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
tracking-firefox53: ? → ---
You need to log in before you can comment on or make changes to this bug.