Closed Bug 1351827 Opened 3 years ago Closed 3 years ago

Current about:home page still uses the old mozilla logo

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 55
Tracking Status
firefox-esr45 --- wontfix
firefox52 - ---
firefox-esr52 - wontfix
firefox53 - wontfix
firefox54 + verified
firefox55 + verified

People

(Reporter: supnah, Assigned: dao)

References

()

Details

Attachments

(4 files)

Current about:home page has the old mozilla logo in the top right of the page. We'd like to a) replace with new logo, and b) pose the question if the URL it points to is still the right one. 

a) Propose replacing with the mozilla logo that can be found here: https://mozilla.ninja/s/Mozilla_Large-Logo_Black-and-white.zip
We recognize that the black and white logo will stand out quite a big more than the current implementation. We'd be ok with a size reduction to make it less imposing. This logo version is our preference, however, if there is a huge amount of pushback for some reason we can work to figure out something else. Hopefully that won't be necessary. 

b) Currently the logo links out to: https://www.mozilla.org/en-US/about which is fine, but the main page of mozilla.org has been updated since that decision was made and actually does a pretty good job talking about who we are and what we do. Just thought I'd throw that out there for consideration.
Hoping to get the logo update into all versions. I know 52 is unlikely, but wanted to track against other versions on the trains.
We are a week away from the 53 release. Can we aim this change at 54?
Flags: needinfo?(bcohen)
Target Milestone: Firefox 52 → ---
FYI. We use "Target Milestone" to mark the cycle where we land a fix (not for planning).
If it's possible to enact the logo swap for 53 that is very much preferable. This is probably the most seen instance of our brand in the product and we really should update it to the new brand. We can help with design mock-ups or if there are other bottlenecks for whoever needs to implement if we can help at all.
Flags: needinfo?(bcohen)
If it's been this way for several releases (Since 50? 51?) and no one noticed until now, then I think we can live with it for 6 more weeks.
I should also say that b/c I'm not intimately aware of the process to make this happen, if it's something you would want to test or try a couple versions of to select the best one, then I'd be super happy just to get that started even if it didn't ship to everyone. Not trying to be rigid in my request, but I do want to see what can be done quickly (but in a responsible way).
That was just my answer to the question about what we should aim for. If we have no choice in the matter that's fine. Just let me know how to assist to get this done as fast as possible.
Yes, good idea! Let's get that process started now, for fixing the logo in 54 release. Design mockups sound like a good plan. Do you know who would be the right team to implement the change? Maybe someone from the product team. I will try to find out. 

Peter, do you have a suggestion here?
Flags: needinfo?(pdehaan)
We're ready to support either by providing mockups or by giving feedback, but happy to look to product on how they'd like to do it. I'll stay tuned and be ready to loop the right people in depending on the decision. Thanks!
Any ideas on best way to move this forward? Perhaps it's best for the brand team to submit some mockups to this bug for review / approval and we can provide the image files if an option is ok'd by the right people?
Flags: needinfo?(lhenry)
Once you have something you like and that works, please attach it and a patch here, ask for review, land the changes on mozilla-central, we can ask QE to verify it if necessary,  and request uplift to beta. 

Peter, can you help out here to find an owner for this bug?
Flags: needinfo?(lhenry)
Thanks, Liz. I don't have a developer resource to whom I can assign this. I would prefer to provide a mockup and any necessary assets (for images if necessary, etc) guidance for someone else to patch. Can we move forward with that plan?
:lizzard: Yeah, as a QE-type-person, I can definitely help verify the new logo is functioning as expected on the about:home page when this lands in Nightly/Beta.

I'm not sure who a developer resource would be, or how to submit a patch/code to moz-central to make this happen.
But it should be a simple file overwrite, as :Dolske mentioned above.
Flags: needinfo?(pdehaan)
Attached file logos_Mozilla.zip
Zip file containing Mozilla logos for use on about:home
Zipped file contains PNGs of the new Mozilla logo and an SVG.

Static state of about:home presents logo at 20% opacity. Hover state at 50% opacity.

Invision prototype here for reference:
https://invis.io/WZBM4HLTN

Feel free to need info me here if any further assets are needed or for clarification of the above static and hover states.
Thanks, Michael. :lizzard: please let me know asap if you think we need to identify our own dev resource to help with this. I don't think that is ideal, but I am willing to investigate if needed. I'd like to have at least identified the way we're going to get this done very soon, even if it takes a little bit to do the work.
Flags: needinfo?(lhenry)
Dão can you help here? I'm asking since you've fixed the most bugs in the new tab component, lately. Thanks!
Flags: needinfo?(lhenry) → needinfo?(dao+bmo)
Thank you, :lizzard:. 

Also - we would love to request that it point at the mozilla.org homepage instead of the /about page. I don't know who, if anyone needs to approve that. Rationale is that the homepage has gone through several iterations since this link was set and I believe it now does a better job of representing us and the variety of things we do than the /about page does. The additional question there is if the utm needs to be adjusted or anything if that switch is made. 

Thank you again!
There are two minor problems with this patch:

- the image slightly bounces around on hover
- zooming in on the page makes the image smaller

I'll file platform bugs on these.
Assignee: nobody → dao+bmo
Component: New Tab Page → General
Flags: needinfo?(dao+bmo)
Thank, Dao!

This patch doesn't address the change in destination URL, correct? Just want to make sure I keep tracking that down if it's not a part of this patch.
(In reply to Bradley Cohen [:supnah] from comment #22)
> Thank, Dao!
> 
> This patch doesn't address the change in destination URL, correct? Just want
> to make sure I keep tracking that down if it's not a part of this patch.

It doesn't. I'd suggest filing a separate bug on this.
Thanks. Will do.
Depends on: 1363140
Depends on: 1363141
Comment on attachment 8865519 [details]
Bug 1351827 - Use new mozilla logo in about:home.

https://reviewboard.mozilla.org/r/137150/#review140640
Attachment #8865519 - Flags: review?(dolske) → review+
Summary: Current about:home page still uses the old mozilla logo. We'd like to update it to the new logo. Also worth examining the URL it directs to. → Current about:home page still uses the old mozilla logo
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eb90f72ce428
Use new mozilla logo in about:home. r=Dolske
https://hg.mozilla.org/mozilla-central/rev/eb90f72ce428
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Sounds like this is something we should backport to all supported branches?
Flags: needinfo?(dao+bmo)
Depends on: 1363090
(In reply to Pascal Chevrel:pascalc from comment #29)
> Is it wanted that the updated logo is tiny compared to the old logo?

This would be bug 1363141. If this affects High DPI rather than just manual zooming, we probably can't uplift this.
Flags: needinfo?(dao+bmo)
I indeed have a highDPI display, looking at the CSS in aboutHome.css, I noticed that we rescale the icons:

.launchButton::before,
  #aboutMozilla::before {
    transform: scale(.5);
    transform-origin: 0 0;
  }


If I change that to:

.launchButton::before {
    transform: scale(.5);
    transform-origin: 0 0;
  }

Then the mozilla icon is correct, I changed my display from 3840x2160 to 1280x720 and the logo was still correct, mentionning in case that may be a potential solution.
(In reply to Pascal Chevrel:pascalc from comment #31)
> I indeed have a highDPI display, looking at the CSS in aboutHome.css, I
> noticed that we rescale the icons:
> 
> .launchButton::before,
>   #aboutMozilla::before {
>     transform: scale(.5);
>     transform-origin: 0 0;
>   }
> 
> 
> If I change that to:
> 
> .launchButton::before {
>     transform: scale(.5);
>     transform-origin: 0 0;
>   }
> 
> Then the mozilla icon is correct, I changed my display from 3840x2160 to
> 1280x720 and the logo was still correct, mentionning in case that may be a
> potential solution.

Nice find. Would you mind attaching a patch? I'll +r it.
Comment on attachment 8866405 [details] [diff] [review]
CSS patch to not scale down the SVG logo

Thanks!
Attachment #8866405 - Flags: review?(dao+bmo) → review+
Should I land the patch for you?
Flags: needinfo?(pascalc)
(In reply to Dão Gottwald [::dao] from comment #35)
> Should I land the patch for you?

Yes please, thanks.
Flags: needinfo?(pascalc)
Comment on attachment 8866405 [details] [diff] [review]
CSS patch to not scale down the SVG logo

>-  .launchButton::before,
>-  #aboutMozilla::before {
>+  .launchButton::before {
>     transform: scale(.5);
>     transform-origin: 0 0;
>   }
> 
>   .launchButton:dir(rtl)::before,
>   #aboutMozilla:dir(rtl)::before {
>     transform: scale(.5) translateX(32px);
>   }

We need to update the second rule too. I'll fix this before landing.
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/33d65dc8e28a
followup: Don't scale down the new mozilla SVG logo for High DPI. r=dao
Managed to reproduce the issue on an affected build (Firefox 55.0a1, build ID:20170510030301) on Windows 10 x 64-bit. New logo has been placed in the "about:home" tab at the top right corner which links out to: https://www.mozilla.org/en-US/about
[bugday-20170510]
¡Hola Fahima!

Yup! The new logo is there on https://hg.mozilla.org/mozilla-central/rev/120d8562d4a53e4f78bd86c6f5076f6db265e5a3

¡Gracias!
Alex
Status: RESOLVED → VERIFIED
See Also: → 1363889
Attached patch patch for upliftSplinter Review
I've tested this patch with beta 54 and esr52 and it works, but I'm not really convinced esr needs this. Anyone feel like making a case for this?

Approval Request for Beta 54:

[Feature/Bug causing the regression]: new Mozilla logo
[User impact if declined]: much confusion about the Mozilla brand :(
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: yes
[List of other uplifts needed for the feature/fix]: /
[Is the change risky?]: only slightly
[Why is the change risky/not risky?]: fairly straightforward image swap, although it turned out a bit bumpy as we switched from PNG to SVG
[String changes made/needed]: /
Attachment #8866546 - Flags: approval-mozilla-beta?
Comment on attachment 8866546 [details] [diff] [review]
patch for uplift

Change the Mozilla logo in about:home page. Beta54+. Should be in 54 beta 7.
Attachment #8866546 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to Dão Gottwald [::dao] from comment #41)
> I'm not really convinced esr needs this. Anyone feel like making a case for this?

Any thoughts on this, Bradley?
Flags: needinfo?(bcohen)
I don't feel strongly about ESR as long as this update would go to it on its next major update (is it Q1 2018 with 59?). If you can confirm that, then no, I agree on no rush to update ESR. 

I would want the new URL (as seen in 1363090) to make it into ESR because that seems like there's no barrier to doing that... but that's over in the other bug anyway.
Flags: needinfo?(bcohen)
I don't think we have a release date set for Fx59/ESR59 yet, but that timeframe is in the right ballpark anyway. Yes, this fix will be in that release. Thanks for the reply.
Flags: qe-verify+
I reproduced this issue using Fx 55.0a1 (20170329071901) using Windows 10 x64.
I can confirm this issue is fixed, I verified using Fx 54.0b7.

Cheers!
Flags: qe-verify+
Duplicate of this bug: 1364108
Depends on: 1384212
You need to log in before you can comment on or make changes to this bug.