Intermittent toolkit/content/tests/browser/browser_mediaPlayback_suspended_multipleAudio.js | The blocked audio can't be playback. - false == true -

RESOLVED FIXED in Firefox 56

Status

()

defect
P5
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Assigned: alwu)

Tracking

({intermittent-failure})

unspecified
mozilla56
Points:
---

Firefox Tracking Flags

(firefox56 fixed)

Details

(Whiteboard: [stockwell fixed:obsolete])

Attachments

(1 attachment)

Component: Audio/Video → Audio/Video: Playback
Flags: needinfo?(alwu)
Close this bug because this issue didn't happen after 4/13.
Free feel to reopen this bug if you see this intermittent fail again.

https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1351925&startday=2017-02-20&endday=2017-04-26&tree=all
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(alwu)
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
while this is failing 21 times, keep in mind that this is only run during peak load once every 5th push, typically that means we are only seeing 25% of the possibly failures- I suspect the failure rate is 60-80 times in the last week if we ran this on every push.

This started up again on the 22nd, I just did some retriggers:
https://treeherder.mozilla.org/#/jobs?repo=autoland&filter-searchStr=linux x64 debug browser-chrome&tochange=6d631ae7ee675a4dff13cde60a8501191b3209ae&fromchange=1f6e4335dabb491e85ca1d89185a1e5d1ac04ca0&selectedJob=109019920

(most are bc3, but one instance is bc2)
Flags: needinfo?(alwu)
and the retriggers point out that bug 1374930 is the root cause!

:jw_wang, as you are the patch author of bug 1374930, can you get a quick resolution (this week) on fixing this intermittent which seems to be a side effect of one of the patches?
Flags: needinfo?(alwu) → needinfo?(jwwang)
I don't think this is a regression from bug 1374930:
1. bug 1374930 doesn't change audio channel code at all.
2. comment 1 indicates the issue went away without any fix.

So it is probably the code changes the timing to make it more likely to happen.

I added some logs for debugging:
https://public-artifacts.taskcluster.net/QHhAjxd4RVurixv_YBBeUw/0/public/logs/live_backing.log
https://hg.mozilla.org/try/rev/fa0162688950667449d6ddefc37562672dd83f86

JWW -- test 1
JWW Play(ErrorResult& aRv) mAudioChannelWrapper=0x7fe82b69c900
JWW IsTabActivated() ShouldBlockMedia=0
JWW IsPlaybackBlocked() IsTabActivated()
JWW PlayInternal()
JWW -- test 2

We should check why mAudioChannelAgent->ShouldBlockMedia() (which is expected to return true in this test) returns false in IsTabActivated().
Flags: needinfo?(jwwang) → needinfo?(alwu)
Will check it later.
Assignee: nobody → alwu
Comment on attachment 8881560 [details]
Bug 1351925 - remove blockMedia() and related tests.

https://reviewboard.mozilla.org/r/152730/#review158754
Attachment #8881560 - Flags: review?(amarchesini) → review+
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2f803b2d8981
remove blockMedia() and related tests. r=baku
https://hg.mozilla.org/mozilla-central/rev/2f803b2d8981
Status: NEW → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Whiteboard: [stockwell fixed:obsolete]
I don't see any occurrences of this failure on Beta for Fx55, but given the patch that landed, I figured I would at least check as to whether we want to let this ride the 56 train or nominate it for Beta approval for 55.
Flags: needinfo?(alwu)
Since this failure was triggered by bug1374930 which was only landed on FF56, I think we don't need to uplift this change to FF55.
Flags: needinfo?(alwu)
You need to log in before you can comment on or make changes to this bug.