Closed Bug 13520 Opened 21 years ago Closed 21 years ago

We aren't getting the To field info from the compose window

Categories

(MailNews Core :: Composition, defect, P1, blocker)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mscott, Assigned: rods)

Details

GFX widgets just got turned on again this afternoon. I just pulled the tree
after they turned it on and tried to send myself a message.

The message never gets sent because the TO field is always coming up blank in
the back end. I'm guessing with GFX text widgets being used, we aren't getting
the data I typed into the To field.
Does this happen for all fields or just 2nd field and beyond?  I am seeing a
problem from this mornings pull where there is no 'id' on nodes that I create
from JS.
Acutally it happens for all fields for me. I'm just entering one To line and we
aren't sending the message because it's not getting a recipient out of that
line. I tried entering it on the 2nd line as well for good measure and still saw
the problem.
Severity: normal → blocker
Priority: P3 → P1
Using builds dated 19990910 on Win98, linux this is blocking testing.  Raising
the Severity to Blocker and making it a P1.  Still testing on Mac.
OS: Windows NT → All
Hardware: PC → All
Changing platform to all, cc'ing phil
QA Contact: lchiang → esther
Adding Rod and Kevin to the cc list in the hopes that they can help us out. The
problem shows up only when gfx is turned on.

Paul and I tracked down this problem to the fact that the popup widget which
contains To/cc/newsgroup/etc. doesn't have a default value assigned to it. In
order to successfully send a message, you need to manually click on this pop up
for each recipient you enter on a line.

Either the gfx widget that implements this pop up isn't assigning a default
value or we need help understanding how to assign a default value for the pop
up.

Relevant code snippets are in:
mailnews\compose\resources\content\addressingWidgetOverlay.js
(Recipients2CompFields)
There's a variable in there: awGetPopupElement which isn't getting a default
value of To/cc/followup. Apparently with a native widget implementation, the
first entry is assigned the default value.
Paul, could you force the entry to avoid the problem?
This bug should be reassigned to rods@netscape.com. He is working on a fix for
the combo box not setting the default issue.
Assignee: hangas → rods
Sending bug to rods per Kevin's suggestion
I have the fix, I'll check it in as soon as I can. it isn't a problem with the
select control, it's in the content node. When asked for the value, it goes and
gets the value. If there is no value it passes back "", what it will do now is
then go get the text content of the option. Also, if no item was selected it get
the zeroth item.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Just checked in the fix.
Status: RESOLVED → VERIFIED
Verified as fixed.
Verified using the following build:
 Win32 Seamonkey build 1999-09-13-09
 Linux Seamonkey build 1999-09-13-09
 MacOS Seamonkey build 1999-09-13-09
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.