locale switching for firefox ui

RESOLVED DUPLICATE of bug 1425941

Status

()

RESOLVED DUPLICATE of bug 1425941
2 years ago
5 months ago

People

(Reporter: mixedpuppy, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Preferences should support changing the language for the primary UI and if it is not possible to update the current windows, Firefox should prompt or suggest a restart.

Bug 1344786 comment #3 has a use case not supported in webextensions.  Preferences (talking about UI, not about:config) do not support changing the locale.  Additionally, when the pref is changed via about:config, the UI in the current window does not refresh.

Comment 1

2 years ago
Bug 377881 is about supporting the switch of the UI language directly in the Fx UI, not only via about:config. About the possibility to let to WebExtensions to do it, I didn't find a related bug. I had planned to open a bug request for it, I will do it later.

Comment 2

5 months ago
bug 1425941 has traction now, resolving as DUPE.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1425941
You need to log in before you can comment on or make changes to this bug.