[PATCH]Cursor is an I-beam when over scrollbar

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
Composer
P3
normal
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Akkana Peck, Assigned: kinmoz)

Tracking

({regression})

Trunk
mozilla1.0
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
In composer, the cursor is an i-beam even when over the scrollbar.  Kin says he
has an easy fix (yay Kin!)

Comment 1

16 years ago
see also bug 132851
(Assignee)

Comment 2

16 years ago
Created attachment 77507 [details] [diff] [review]
Patch Rev 1

This patch qualifies a bit more what should use the text cursor. The
scrolled-content pseudo refers to the actual content area frame which I believe
is a sibling of the scrollbars so it prevents scrollbars from inheriting the
text cursor.
(Assignee)

Comment 3

16 years ago
Cc'ing sfraser for super review ... anyone else want to review?
Status: NEW → ASSIGNED
Keywords: mozilla1.0, nsbeta1, regression
Priority: -- → P3
Whiteboard: FIX IN HAND, need r=, sr=, a=
Target Milestone: --- → mozilla1.0
Comment on attachment 77507 [details] [diff] [review]
Patch Rev 1

yay ! make that land asap !
r=glazman
Attachment #77507 - Flags: review+

Comment 5

16 years ago
Comment on attachment 77507 [details] [diff] [review]
Patch Rev 1

sr=sfraser
Attachment #77507 - Flags: superreview+

Comment 6

16 years ago
*** Bug 132851 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Whiteboard: FIX IN HAND, need r=, sr=, a= → FIX IN HAND, need a=
nsbeta1+
Keywords: nsbeta1 → nsbeta1+
Summary: Cursor is an I-beam when over scrollbar → [PATCH]Cursor is an I-beam when over scrollbar
Whiteboard: FIX IN HAND, need a= → [adt2]FIX IN HAND, need a=
(Assignee)

Updated

16 years ago
Keywords: adt1.0.0

Comment 8

16 years ago
adt1.0.0+ (on ADT's behalf) for approval for checkin.
Keywords: adt1.0.0 → adt1.0.0+

Comment 9

16 years ago
Comment on attachment 77507 [details] [diff] [review]
Patch Rev 1

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #77507 - Flags: approval+
(Assignee)

Comment 10

16 years ago
Fix checked into the TRUNK:

    mozilla/editor/ui/composer/content/EditorOverride.css  revision 1.21
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Updated

16 years ago
Whiteboard: [adt2]FIX IN HAND, need a= → [adt2]

Updated

16 years ago
Keywords: fixed1.0.0

Comment 11

16 years ago
verified in 4/23 trunk.

will verify on the branch also and comment here.
Status: RESOLVED → VERIFIED

Comment 12

16 years ago
verified in 4/23 branch build.
Keywords: verified1.0.0
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.