Add Raven.js license for Screenshots

RESOLVED FIXED in Firefox 54

Status

()

Firefox
General
RESOLVED FIXED
2 months ago
29 days ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

unspecified
Firefox 55
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox54 fixed, firefox55 fixed)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

2 months ago
Screenshots is using the Raven.js library in their system add-on that is being added in bug 1346825.

This bug is to add the license it to about:license and get approval for it.
(Assignee)

Updated

2 months ago
Comment hidden (mozreview-request)

Comment 2

2 months ago
mozreview-review
Comment on attachment 8853386 [details]
Bug 1352387 - Add Raven.js license for Screenshots.

https://reviewboard.mozilla.org/r/125500/#review128536

::: toolkit/content/license.html:4912
(Diff revision 1)
> +    <hr>
> +
> +    <h1><a id="raven-js"></a>Raven.js License</h1>
> +
> +    <p>This license applies to certain files in the directory
> +      <span class="path">browser/extensions/screenshots/webextension/build/raven.js</span>.</p>

Assuming this is actually a directory and not a file, this is fine. :-)
Attachment #8853386 - Flags: review?(gerv) → review+
(Assignee)

Comment 3

a month ago
mozreview-review-reply
Comment on attachment 8853386 [details]
Bug 1352387 - Add Raven.js license for Screenshots.

https://reviewboard.mozilla.org/r/125500/#review128536

> Assuming this is actually a directory and not a file, this is fine. :-)

Thanks for picking that up, I've changed it to "This license applies to the file" which is used elsewhere.
(Assignee)

Comment 4

a month ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/b651a6de3cede2ec942d9071fbf00c800d59326a
Bug 1352387 - Add Raven.js license for Screenshots. r=gerv
(Assignee)

Comment 5

a month ago
Created attachment 8857873 [details] [diff] [review]
Bug 1352387 - Add Raven.js license for Screenshots.

Since I pushed this direct to mozilla-inbound, here's the actual patch I pushed.
Attachment #8853386 - Attachment is obsolete: true
Backed this out in https://hg.mozilla.org/integration/mozilla-inbound/rev/4167136e1ddf because I had to back out bug 1346825 for devtools bustage, and I wasn't sure if this could live on its own.
Flags: needinfo?(standard8)
(Assignee)

Comment 7

a month ago
(In reply to Wes Kocher (:KWierso) from comment #6)
> Backed this out in
> https://hg.mozilla.org/integration/mozilla-inbound/rev/4167136e1ddf because
> I had to back out bug 1346825 for devtools bustage, and I wasn't sure if
> this could live on its own.

Yeah, it wouldn't have mattered, but ideally these should land together.
Flags: needinfo?(standard8)

Comment 8

a month ago
Pushed by dtownsend@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1114810135e3
Add Raven.js license for Screenshots. r=gerv
https://hg.mozilla.org/mozilla-central/rev/1114810135e3
Status: NEW → RESOLVED
Last Resolved: a month ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Comment on attachment 8857873 [details] [diff] [review]
Bug 1352387 - Add Raven.js license for Screenshots.

Approval Request Comment
[Feature/Bug causing the regression]:
No regression. This lands Firefox Screenshots (https://wiki.mozilla.org/Firefox/Screenshots) in Beta 54.

[User impact if declined]:
Screenshots has been identified as a top line feature for the 54 launch (based on high user engagement through Test Pilot), not landing will affect org-wide goals.

[Is this code covered by automated tests?]:
Some, yes.

[Has the fix been verified in Nightly?]:
Yes, https://github.com/mozilla-services/screenshots/issues/2681#issuecomment-295300379

[Needs manual test from QE? If yes, steps to reproduce]: 
No.

[List of other uplifts needed for the feature/fix]:
4 patches in bug 1346825, and 1 in bug 1352387.

[Is the change risky?]:
Mildly.

[Why is the change risky/not risky?]:
Risky because it's a product feature that didn't bake in Nightly/Aurora, not that risky because we are landing it pref'd off, and doing a staged rollout via a system add-on (bug 1351424).


[String changes made/needed]:
None.
Attachment #8857873 - Flags: approval-mozilla-beta?

Updated

a month ago
status-firefox54: --- → affected
Comment on attachment 8857873 [details] [diff] [review]
Bug 1352387 - Add Raven.js license for Screenshots.

Support screenshot feature in 54. Beta54+. Should be in 54 beta 2.
Attachment #8857873 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 12

a month ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/3f2155a90b02
status-firefox54: affected → fixed
Bug 1346825 got backed out, so backed this out with it:
https://hg.mozilla.org/releases/mozilla-beta/rev/2ef0f8e1ba371f63bdd53112bac1603a2e077b99
status-firefox54: fixed → affected
Flags: needinfo?(standard8)
https://hg.mozilla.org/releases/mozilla-beta/rev/bb3319dc41bf
status-firefox54: affected → fixed
Flags: needinfo?(standard8)
(In reply to Cory Price [:ckprice] from comment #10)
> [Is this code covered by automated tests?]:
> Some, yes.
> [Needs manual test from QE? If yes, steps to reproduce]: 
> No.

Setting qe-verify- based on Cory's assessment on manual testing needs and the fact that this fix has automated coverage.
Flags: qe-verify-
I have reproduce this bug with Nightly 55.0a1 (2017-03-31) (64- bit) in Windows 10.

This bug's fix is verified with latest Beta 54.0b3 and latest Nightly 55.0a1 (64-bit).
 
Build ID   :	20170427091925
User Agent :	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0


Build ID   :     20170428030259
User Agent : 	 Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0


[testday-20170428]
You need to log in before you can comment on or make changes to this bug.