If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Kongregate's Stage3D Flash games don't load

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P1
normal
RESOLVED WORKSFORME
6 months ago
28 days ago

People

(Reporter: jimm, Unassigned)

Tracking

({regression, regressionwindow-wanted})

Trunk
All
Windows
regression, regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(firefox52 unaffected, firefox-esr52 unaffected, firefox53- unaffected, firefox54 unaffected, firefox55 unaffected)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

6 months ago
STR:

1) Go to http://www.kongregate.com/games/ConArtists/the-last-stand-dead-zone
2) Log in and try to load the game

result: stuck on loading splash screen.

32/64 bit builds, all releases.
(Reporter)

Comment 1

6 months ago
Hey Stefan, can you please have someone confirm this and check for a regression range? Thanks.
Flags: needinfo?(stefan.georgiev)
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

6 months ago
Created attachment 8853400 [details]
splash screen

Comment 3

6 months ago
Created attachment 8853561 [details]
Splash screen - connecting error with asyndrawing = false.PNG

I`m able to load and play the game only with the official Firefox release version (52.0a1). On all other versions is showing either black screen with spinner which never loads with dom.ipc.plugins.asyncdrawing.enabled = true or it is showing the game splash screen with "Connect Error" text right next to the spinner with dom.ipc.plugins.asyncdrawing.enabled = false. 

When trying to use mozregression I could not find any version that loads the game. Even I tried to load it with Nightly 30 or 15 but I`m getting the same result.
Flags: needinfo?(stefan.georgiev)

Comment 4

6 months ago
Created attachment 8853562 [details]
Black screen - connecting failed - 31.0a1.PNG
(Reporter)

Comment 5

6 months ago
[Tracking Requested - why for this release]:
serious flash rendering regression
status-firefox52: --- → unaffected
status-firefox53: --- → affected
status-firefox54: --- → affected
status-firefox-esr52: --- → unaffected
tracking-firefox53: --- → ?

Updated

6 months ago
Priority: -- → P1
(Reporter)

Comment 6

6 months ago
Hey Liz - discussing this with bsmedberg, we both felt this bug should block shipping 53 until we know more about it. Tracy 

Tracy, we really need a regression range here.
Flags: needinfo?(lhenry)
(Reporter)

Updated

6 months ago
Flags: needinfo?(twalker)
Marking this as a release blocker for 53. Time is tight here since the release date is April 18.
tracking-firefox53: ? → blocking
Flags: needinfo?(lhenry)

Comment 8

6 months ago
With Fx 53.0b9, 20170403072723 (32bit) on Win 7 using Adobe Flash Player 25.0.0.143 (beta) or AFP 25.0.0.127 (release) and asyncDrawing enabled the Kongregate, The Last Stand: Dead Zone game loads up and works as expected.  
 
The game also works with asyncDrawing disabled.

Note: This site/game gets randomly slow while the page is dealing with advertisements; contacting ad servers, connecting to google etc. This happens extensively to the point the browser repeatedly puts up the slow page warning.  I don't see how anyone could stand to play this game with out an ad free, paid subscriptions. 

I'm not sure why you're not able to load the game, other than ads.  The game doesn't load immediately on page load because the site makes you wait for ad(s). There is a message saying the game will be loaded after the ad.  Other than that, what version(s) of Adobe Flash Player are you using?
Flags: needinfo?(twalker)
(Reporter)

Comment 9

6 months ago
(In reply to Tracy Walker [:tracy] from comment #8)
> With Fx 53.0b9, 20170403072723 (32bit) on Win 7 using Adobe Flash Player
> 25.0.0.143 (beta) or AFP 25.0.0.127 (release) and asyncDrawing enabled the
> Kongregate, The Last Stand: Dead Zone game loads up and works as expected.  
>  
> The game also works with asyncDrawing disabled.
> 
> Note: This site/game gets randomly slow while the page is dealing with
> advertisements; contacting ad servers, connecting to google etc. This
> happens extensively to the point the browser repeatedly puts up the slow
> page warning.  I don't see how anyone could stand to play this game with out
> an ad free, paid subscriptions. 
> 
> I'm not sure why you're not able to load the game, other than ads.  The game
> doesn't load immediately on page load because the site makes you wait for
> ad(s). There is a message saying the game will be loaded after the ad. 
> Other than that, what version(s) of Adobe Flash Player are you using?

Yeah this site is a mess. I've been diagnosing this as well because I think I'm getting false negatives thanks to the latency and bugginess of the web site.

Here's my 'guaranteed to work!' STR:

1) Using mozregression (fresh profile, prefs control):
mach mozregression --pref "dom.ipc.plugins.asyncdrawing.enabled:false" --good xxx --bad xxx --bits 32
2) load the game page (http://www.kongregate.com/games/ConArtists/the-last-stand-dead-zone)
3) over on the right, click chat, then click sign-in at the bottom of the panel
4) moztester123/lemmings
5) wait while the invisible advertisement plays with the dots spinner. message at the bottom of the game should read 
"Your game will start after this message (close)". don't click close, just let it play out and transition.
5) wait for the game to load

The game should display a splash screen that says "loading assets". This generally indicates the game is loading properly. To confirm, wait a bit longer, eventually the game should get to a character selection interface.

I'm still working through dates, but it looks like I might be able to resolve this bug as wfm here once I'm through.
(Reporter)

Comment 10

6 months ago
kong game, 32-bit nightly, fresh profile, async drawing off
-----------------------------------------------------------
11-10 - works
11-14 - works
12-01 - works
02-01 - works
04-01 - works

kong game, 32-bit nightly, fresh profile, async drawing on
-----------------------------------------------------------
02-01 - works
04-01 - works
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WORKSFORME
Jimm, thanks for checking up on this. False alarm!
status-firefox53: affected → unaffected
status-firefox54: affected → unaffected
status-firefox55: affected → unaffected
tracking-firefox53: blocking → -
(Reporter)

Updated

28 days ago
Duplicate of this bug: 1353768
You need to log in before you can comment on or make changes to this bug.