Can't add Yahoo Search To Search box if it has been removed manually.

NEW
Unassigned

Status

()

2 years ago
2 years ago

People

(Reporter: pete, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170323105023

Steps to reproduce:

Search box --> Change Search Settings--> Remove Yahoo Search

Now browse to Yahoo.com

Click on Search box.  You are prompted to add yahoo Search as an option.  When you attempt to, it fails.


Actual results:

Fails with a message stating an engine with the same name already exists.


Expected results:

While one can return yahoo search manually by clicking on "restore default search engines,"  Many users might not know that Yahoo is/was a default search engine.  Or many users might want yahoo search back after seeing the prompt in the search box.  The error message seems superfluous, why not just add the default yahoo search (or other engine?)

Updated

2 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → Search
Ever confirmed: true

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1208768

Comment 2

2 years ago
sorry spam,

This is not actually dup.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

2 years ago
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.