Closed Bug 1352456 Opened 4 years ago Closed 4 years ago

Thunderbird Nightly build fails with IOError: [Errno 2] No such file or directory: 'c:\\builds\\relengapi.tok'

Categories

(Release Engineering :: General, defect)

All
Windows
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1365219

People

(Reporter: Paenglab, Unassigned)

Details

(Whiteboard: [Thunderbird-testfailure: B Windows])

Since Mar 30. Thunderbird Nightly builds fails, no matter if 32bit or 64bit. Normal builds finishes successfully. See https://archive.mozilla.org/pub/thunderbird/nightly/2017/03/2017-03-31-03-02-13-comm-central/comm-central-win64-nightly-bm91-build1-build3.txt.gz for example.

In log I see:

Executing: ['python.exe', 'c:/mozilla-build/tooltool.py', '--authentication-file', 'c:\\builds\\relengapi.tok', '--url', 'https://api.pub.build.mozilla.org/tooltool/', '--overwrite', '-m', 'mail/config/tooltool-manifests/win64/releng.manifest', 'fetch', '-c', 'c:/builds/tooltool_cache']
INFO - File mozmake.exe not present in local cache folder c:/builds/tooltool_cache
INFO - Attempting to fetch from 'https://api.pub.build.mozilla.org/tooltool/'...
INFO - failed to write to temporary file for 'mozmake.exe'
Traceback (most recent call last):
  File "c:/mozilla-build/tooltool.py", line 471, in fetch_file
    _authorize(req, auth_file)
  File "c:/mozilla-build/tooltool.py", line 756, in _authorize
    'Bearer %s' % (open(auth_file).read().strip()))
IOError: [Errno 2] No such file or directory: 'c:\\builds\\relengapi.tok'
INFO - File rustc.tar.bz2 not present in local cache folder c:/builds/tooltool_cache
INFO - Attempting to fetch from 'https://api.pub.build.mozilla.org/tooltool/'...
INFO - failed to write to temporary file for 'rustc.tar.bz2'
Traceback (most recent call last):
  File "c:/mozilla-build/tooltool.py", line 471, in fetch_file
    _authorize(req, auth_file)
  File "c:/mozilla-build/tooltool.py", line 756, in _authorize
    'Bearer %s' % (open(auth_file).read().strip()))
IOError: [Errno 2] No such file or directory: 'c:\\builds\\relengapi.tok'
INFO - File sccache2.tar.bz2 not present in local cache folder c:/builds/tooltool_cache
INFO - Attempting to fetch from 'https://api.pub.build.mozilla.org/tooltool/'...
INFO - failed to write to temporary file for 'sccache2.tar.bz2'
Traceback (most recent call last):
  File "c:/mozilla-build/tooltool.py", line 471, in fetch_file
    _authorize(req, auth_file)
  File "c:/mozilla-build/tooltool.py", line 756, in _authorize
    'Bearer %s' % (open(auth_file).read().strip())) ...
Rail, do you know what could be the issue?
Flags: needinfo?(rail)
Maybe the machine configuration changed recently? :grenade, any idea?
Flags: needinfo?(rail) → needinfo?(rthijssen)
Whiteboard: [Thunderbird-testfailure: N Windows]
Failed on 30th and 31st of March 2017, worked again on 1st April 2017. I was going to wait for three consecutive failures before reporting it, but Richard was more impatient ;-)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
It works only because I filed it. ;-)
Flags: needinfo?(rthijssen)
Started failing heavily again on Tue May 16, 2017, 8:00:36, since then, some Windows builds worked, others didn't.

From the log of a failed one:
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=a09ebe0269abee8765beb01e997ecfa6dff01372&selectedJob=99490399

https://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-win32-debug/1494957320/comm-central-win32-debug-bm91-build1-build35.txt.gz

Fetching...
Executing: ['python.exe', 'c:/mozilla-build/tooltool.py', '--authentication-file', 'c:\\builds\\relengapi.tok', '--url', 'https://api.pub.build.mozilla.org/tooltool/', '--overwrite', '-m', 'mail/config/tooltool-manifests/win32/releng.manifest', 'fetch', '-c', 'c:/builds/tooltool_cache']
INFO - File mozmake.exe not present in local cache folder c:/builds/tooltool_cache
INFO - Attempting to fetch from 'https://api.pub.build.mozilla.org/tooltool/'...
INFO - failed to write to temporary file for 'mozmake.exe'
Traceback (most recent call last):
  File "c:/mozilla-build/tooltool.py", line 471, in fetch_file
    _authorize(req, auth_file)
  File "c:/mozilla-build/tooltool.py", line 756, in _authorize
    'Bearer %s' % (open(auth_file).read().strip()))
IOError: [Errno 2] No such file or directory: 'c:\\builds\\relengapi.tok'
INFO - File rustc.tar.bz2 not present in local cache folder c:/builds/tooltool_cache
INFO - Attempting to fetch from 'https://api.pub.build.mozilla.org/tooltool/'...
INFO - failed to write to temporary file for 'rustc.tar.bz2'
Traceback (most recent call last):
  File "c:/mozilla-build/tooltool.py", line 471, in fetch_file
    _authorize(req, auth_file)
  File "c:/mozilla-build/tooltool.py", line 756, in _authorize
    'Bearer %s' % (open(auth_file).read().strip()))
IOError: [Errno 2] No such file or directory: 'c:\\builds\\relengapi.tok'
INFO - File sccache2.tar.bz2 not present in local cache folder c:/builds/tooltool_cache
INFO - Attempting to fetch from 'https://api.pub.build.mozilla.org/tooltool/'...
INFO - failed to write to temporary file for 'sccache2.tar.bz2'
Traceback (most recent call last):
  File "c:/mozilla-build/tooltool.py", line 471, in fetch_file
    _authorize(req, auth_file)
  File "c:/mozilla-build/tooltool.py", line 756, in _authorize
    'Bearer %s' % (open(auth_file).read().strip()))
IOError: [Errno 2] No such file or directory: 'c:\\builds\\relengapi.tok'

So let's repeat the question from comment #1 to Rail since :grenade is not taking NI requests right now.
Status: RESOLVED → REOPENED
Flags: needinfo?(rail)
Resolution: WORKSFORME → ---
Whiteboard: [Thunderbird-testfailure: N Windows] → [Thunderbird-testfailure: B Windows]
Let's ask Mark! :)
Flags: needinfo?(rail) → needinfo?(mcornmesser)
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Flags: needinfo?(mcornmesser)
Resolution: --- → DUPLICATE
Duplicate of bug: 1365219
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.