Debugger hover shows incorrect value

RESOLVED DUPLICATE of bug 1309974

Status

()

Firefox
Developer Tools: Debugger
RESOLVED DUPLICATE of bug 1309974
a year ago
6 months ago

People

(Reporter: botond, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox55 affected)

Details

(Reporter)

Description

a year ago
STR:
  1. Load an HTML file with the following content:

       <script>
         var f = function() {
           var foo = {};
           foo.bar = 42;
           var bar = 4;
           if (foo.bar > 41) {
             console.log(foo.bar);
           }
         };
         f();
       </script>

  2. Open the debugger and put a breakpoint on the
     console.log line.
  3. Refresh the page so the breakpoint is hit.
  4. Hover over |bar| in |if (foo.bar > 41)|.

Expected results:
  The hover shows 42.

Actual results:
  The hover shows 4.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1309974
You need to log in before you can comment on or make changes to this bug.