If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent PROCESS-CRASH | file:///c:/slave/test/build/tests/jsreftest/tests/jsreftest.html?test=test262/built-ins/RegExp/prototype/Symbol.split/str-limit-capturing.js | application crashed [@ MessageLoop::DeletePendingTasks()]

RESOLVED DUPLICATE of bug 1355196

Status

()

Core
JavaScript: Standard Library
RESOLVED DUPLICATE of bug 1355196
6 months ago
2 months ago

People

(Reporter: aryx, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

https://treeherder.mozilla.org/logviewer.html#?job_id=88071206&repo=autoland

07:08:55     INFO - Assertion failure: work_queue_.empty(), at c:/builds/moz2_slave/autoland-w32-d-000000000000000/build/src/ipc/chromium/src/base/message_loop.cc:410
07:09:06     INFO - #01: base::Thread::ThreadMain() [ipc/chromium/src/base/thread.cc:196]
07:09:06     INFO - 
07:09:06     INFO - #02: `anonymous namespace'::ThreadFunc [ipc/chromium/src/base/platform_thread_win.cc:29]
07:09:06     INFO - 
07:09:06     INFO - #03: kernel32.dll + 0x53c45
07:09:06     INFO - 
07:09:06     INFO - #04: ntdll.dll + 0x637f5
07:09:06     INFO - 
07:09:06     INFO - #05: ntdll.dll + 0x637c8
07:09:06     INFO - 
07:09:06     INFO - TEST-UNEXPECTED-FAIL | file:///c:/slave/test/build/tests/jsreftest/tests/jsreftest.html?test=test262/built-ins/RegExp/prototype/Symbol.split/str-limit-capturing.js | application terminated with exit code 1
07:09:06     INFO - REFTEST INFO | Copy/paste: c:\slave\test\build\win32-minidump_stackwalk.exe c:\users\cltbld\appdata\local\temp\tmpqpmykb.mozrunner\minidumps\90b3aae6-4521-4263-bf94-8e9d714a5e26.dmp c:\slave\test\build\symbols
07:09:24     INFO - REFTEST INFO | Saved minidump as c:\slave\test\build\blobber_upload_dir\90b3aae6-4521-4263-bf94-8e9d714a5e26.dmp
07:09:24     INFO - REFTEST INFO | Saved app info as c:\slave\test\build\blobber_upload_dir\90b3aae6-4521-4263-bf94-8e9d714a5e26.extra
07:09:24     INFO - REFTEST PROCESS-CRASH | file:///c:/slave/test/build/tests/jsreftest/tests/jsreftest.html?test=test262/built-ins/RegExp/prototype/Symbol.split/str-limit-capturing.js | application crashed [@ MessageLoop::DeletePendingTasks()]
07:09:24     INFO - Crash dump filename: c:\users\cltbld\appdata\local\temp\tmpqpmykb.mozrunner\minidumps\90b3aae6-4521-4263-bf94-8e9d714a5e26.dmp
07:09:24     INFO - Operating system: Windows NT
07:09:24     INFO -                   6.1.7601 Service Pack 1
07:09:24     INFO - CPU: x86
07:09:24     INFO -      GenuineIntel family 6 model 62 stepping 4
07:09:24     INFO -      8 CPUs
07:09:24     INFO - 
07:09:24     INFO - GPU: UNKNOWN
07:09:24     INFO - 
07:09:24     INFO - Crash reason:  EXCEPTION_BREAKPOINT
07:09:24     INFO - Crash address: 0x5ea0866c
07:09:24     INFO - Process uptime: 2264 seconds
07:09:24     INFO - 
07:09:24     INFO - Thread 4 (crashed)
07:09:24     INFO -  0  xul.dll!MessageLoop::DeletePendingTasks() [message_loop.cc:7bc9570270b3 : 410 + 0x18]
07:09:24     INFO -     eip = 0x5ea0866c   esp = 0x06ccfae8   ebp = 0x06ccfb10   ebx = 0x06ccfb80
07:09:24     INFO -     esi = 0x0000019a   edi = 0x00000000   eax = 0x00000000   ecx = 0x697a06ef
07:09:24     INFO -     edx = 0x00000060   efl = 0x00000216
07:09:24     INFO -     Found by: given as instruction pointer in context
07:09:24     INFO -  1  xul.dll!MessageLoop::~MessageLoop() [message_loop.cc:7bc9570270b3 : 189 + 0x7]
07:09:24     INFO -     eip = 0x5ea06629   esp = 0x06ccfaf4   ebp = 0x06ccfb10
07:09:24     INFO -     Found by: call frame info
07:09:24     INFO -  2  xul.dll!base::Thread::ThreadMain() [thread.cc:7bc9570270b3 : 196 + 0x11]
07:09:24     INFO -     eip = 0x5ea0dc68   esp = 0x06ccfb18   ebp = 0x06ccfbe4
07:09:24     INFO -     Found by: call frame info
07:09:24     INFO -  3  xul.dll!`anonymous namespace'::ThreadFunc [platform_thread_win.cc:7bc9570270b3 : 28 + 0x8]
07:09:24     INFO -     eip = 0x5e9fdd48   esp = 0x06ccfbec   ebp = 0x06ccfbec
07:09:24     INFO -     Found by: call frame info
07:09:24     INFO -  4  kernel32.dll!BaseThreadInitThunk + 0x12
07:09:24     INFO -     eip = 0x77053c45   esp = 0x06ccfbf4   ebp = 0x06ccfbf8
07:09:24     INFO -     Found by: call frame info
07:09:24     INFO -  5  ntdll.dll!__RtlUserThreadStart + 0x27
07:09:24     INFO -     eip = 0x773337f5   esp = 0x06ccfc00   ebp = 0x06ccfc38
07:09:24     INFO -     Found by: call frame info
07:09:24     INFO -  6  ntdll.dll!_RtlUserThreadStart + 0x1b
07:09:24     INFO -     eip = 0x773337c8   esp = 0x06ccfc40   ebp = 0x06ccfc50
07:09:24     INFO -     Found by: call frame info

Comment 1

3 months ago
1 failures in 814 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-central: 1

Platform breakdown:
* windows7-32-vm: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1352719&startday=2017-06-12&endday=2017-06-18&tree=all

Comment 2

2 months ago
1 failures in 720 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 1

Platform breakdown:
* windows7-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1352719&startday=2017-07-10&endday=2017-07-16&tree=all
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1355196
You need to log in before you can comment on or make changes to this bug.