Closed Bug 1352791 Opened 3 years ago Closed 2 years ago

Intermittent browser/base/content/test/alerts/browser_notification_do_not_disturb.js | Test timed out -

Categories

(Toolkit :: Notifications and Alerts, defect, P2)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox56 --- disabled
firefox57 --- disabled
firefox58 --- disabled

People

(Reporter: aryx, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: intermittent-failure, leave-open, Whiteboard: [stockwell disabled])

Attachments

(2 files)

Another one of these notification or popup failures on Windows 7 VM taskcluster.

https://treeherder.mozilla.org/logviewer.html#?job_id=88125995&repo=autoland

03:32:21     INFO -  92 INFO TEST-START | browser/base/content/test/alerts/browser_notification_close.js
03:32:21     INFO -  GECKO(3736) | ++DOMWINDOW == 25 (19DDA800) [pid = 3736] [serial = 25] [outer = 1559F400]
03:32:21     INFO -  GECKO(3736) | ++DOCSHELL 1A70D000 == 11 [pid = 3736] [id = {7a902dbd-bf5e-46e6-879c-94c7b2063a54}]
03:32:21     INFO -  GECKO(3736) | ++DOMWINDOW == 26 (1A70DC00) [pid = 3736] [serial = 26] [outer = 00000000]
03:32:21     INFO -  GECKO(3736) | [3736] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/caps/BasePrincipal.cpp, line 380
03:32:21     INFO -  GECKO(3736) | ++DOMWINDOW == 27 (1A70F400) [pid = 3736] [serial = 27] [outer = 1A70DC00]
03:32:21     INFO -  GECKO(3736) | [3736] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/caps/BasePrincipal.cpp, line 380
03:32:21     INFO -  GECKO(3736) | [3736] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/caps/BasePrincipal.cpp, line 380
03:32:21     INFO -  GECKO(3736) | [3736] WARNING: Could not get disk status from nsIDiskSpaceWatcher: file z:/build/build/src/uriloader/prefetch/nsOfflineCacheUpdateService.cpp, line 284
03:32:21     INFO -  GECKO(3736) | ++DOMWINDOW == 28 (1AA2A400) [pid = 3736] [serial = 28] [outer = 1A70DC00]
03:32:21     INFO -  GECKO(3736) | [3736] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/xhr/XMLHttpRequestMainThread.cpp, line 2000
03:32:21     INFO -  GECKO(3736) | [3736] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/xhr/XMLHttpRequestMainThread.cpp, line 2000
03:32:22     INFO -  GECKO(3736) | [3736] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/xhr/XMLHttpRequestMainThread.cpp, line 2000
03:32:25     INFO -  GECKO(3736) | --DOCSHELL 0DD3A800 == 10 [pid = 3736] [id = {f69242d1-a4b4-4142-8516-7ac429532d46}]
03:32:27     INFO -  GECKO(3736) | --DOCSHELL 13FB6C00 == 9 [pid = 3736] [id = {5cbf839a-e390-450e-8ad8-f45e589f03d6}]
03:32:27     INFO -  GECKO(3736) | --DOCSHELL 0C69E400 == 8 [pid = 3736] [id = {6c6ec9b8-ab9d-4b95-9906-f7df0088c189}]
03:32:39     INFO -  GECKO(3736) | --DOMWINDOW == 27 (1A70F400) [pid = 3736] [serial = 27] [outer = 00000000] [url = about:blank]
03:32:39     INFO -  GECKO(3736) | --DOMWINDOW == 26 (155A1400) [pid = 3736] [serial = 24] [outer = 00000000] [url = about:blank]
03:32:39     INFO -  GECKO(3736) | --DOMWINDOW == 25 (0D117800) [pid = 3736] [serial = 14] [outer = 00000000] [url = about:blank]
03:32:39     INFO -  GECKO(3736) | --DOMWINDOW == 24 (11152400) [pid = 3736] [serial = 9] [outer = 00000000] [url = about:blank]
03:32:39     INFO -  GECKO(3736) | --DOMWINDOW == 23 (0DF65800) [pid = 3736] [serial = 4] [outer = 00000000] [url = about:blank]
03:32:41     INFO -  GECKO(3736) | --DOMWINDOW == 22 (0DD3A000) [pid = 3736] [serial = 8] [outer = 00000000] [url = chrome://gfxsanity/content/sanitytest.html]
03:32:41     INFO -  GECKO(3736) | --DOMWINDOW == 21 (0DD3AC00) [pid = 3736] [serial = 1] [outer = 00000000] [url = chrome://gfxsanity/content/sanityparent.html]
03:32:41     INFO -  GECKO(3736) | --DOMWINDOW == 20 (13FB7000) [pid = 3736] [serial = 13] [outer = 00000000] [url = about:blank]
03:32:44     INFO -  GECKO(3736) | --DOMWINDOW == 19 (0D10E000) [pid = 3736] [serial = 10] [outer = 00000000] [url = chrome://gfxsanity/content/sanitytest.html]
03:32:44     INFO -  GECKO(3736) | --DOMWINDOW == 18 (0DD3B000) [pid = 3736] [serial = 2] [outer = 00000000] [url = about:blank]
03:32:44     INFO -  GECKO(3736) | --DOMWINDOW == 17 (14007C00) [pid = 3736] [serial = 17] [outer = 00000000] [url = about:blank]
03:32:44     INFO -  GECKO(3736) | --DOMWINDOW == 16 (17A04800) [pid = 3736] [serial = 18] [outer = 00000000] [url = about:blank]
03:33:51     INFO -  TEST-INFO | started process screenshot
03:33:51     INFO -  TEST-INFO | screenshot: exit 0
03:33:51     INFO -  Buffered messages logged at 03:32:21
03:33:51     INFO -  93 INFO Entering test bound test_notificationClose
03:33:51     INFO -  Buffered messages finished
03:33:51    ERROR -  94 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/alerts/browser_notification_close.js | Test timed out -
Whiteboard: [stockwell unknown]
Duplicate of this bug: 1391436
this is the second week in a row of high failures:
https://brasstacks.mozilla.com/orangefactor/index.html?display=Bug&bugid=1352791

heavily on win7 (opt/debug/pgo), not sure why 32 bit windows is problematic.  This has been lingering around pretty consistently a few times/week for the last 5 months.

:mattn, could you look into this or help find someone who knows about this test/code to look at it, ideally resolving it in the next week or two?
Flags: needinfo?(MattN+bmo)
Without a regression range I don't know anyone who has time to work on this in the next week. rs=me to disable on Windows debug builds as it may be a race condition.
Flags: needinfo?(MattN+bmo)
Priority: -- → P1
is it ok to disable on all of windows 7 instead- I see the latest trend showing a fairly equal distribution of opt/pgo/debug- still on windows 7 primarily
Flags: needinfo?(MattN+bmo)
Sure. Thanks
Flags: needinfo?(MattN+bmo)
Attachment #8905434 - Flags: review?(gbrown) → review+
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/90c6c33b5604
Disable browser/base/content/test/alerts/browser_notification_do_not_disturb.js on windows 7. r=gbrown
Keywords: leave-open
Whiteboard: [stockwell unknown] → [stockwell disabled]
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
$ ./mach test browser/base/content/test/alerts/ --verify
…
::: Test verification summary for:
:::
::: browser/base/content/test/alerts/browser_notification_close.js
::: browser/base/content/test/alerts/browser_notification_do_not_disturb.js
::: browser/base/content/test/alerts/browser_notification_open_settings.js
::: browser/base/content/test/alerts/browser_notification_remove_permission.js
::: browser/base/content/test/alerts/browser_notification_replace.js
::: browser/base/content/test/alerts/browser_notification_tab_switching.js
:::
::: 1. Run each test 10 times in one browser. : Pass
::: 2. Run each test 5 times in a new browser each time. : Pass
::: 3. Run each test 10 times in one browser, in chaos mode. : Pass
::: 4. Run each test 5 times in a new browser each time, in chaos mode. : Pass

Going to test this on try now…
Comment on attachment 8916804 [details]
Bug 1352791 - Use a pushPermissions helper for alerts b-c tests.

https://reviewboard.mozilla.org/r/187874/#review192950
Attachment #8916804 - Flags: review?(MattN+bmo) → review+
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 0838676cb13b -d db3f44db75c5: rebasing 424898:0838676cb13b "Bug 1352791 - Use a pushPermissions helper for alerts b-c tests. r=MattN" (tip)
merging browser/base/content/test/alerts/browser_notification_open_settings.js
warning: conflicts while merging browser/base/content/test/alerts/browser_notification_open_settings.js! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/mozilla-inbound/rev/314590a2d588
Use a pushPermissions helper for alerts b-c tests. r=MattN
https://hg.mozilla.org/mozilla-central/rev/314590a2d588
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
This still fails, see e.g. https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=42bcbbdc84f22bdd0960177066fad4382d3545bc&filter-searchStr=e24e60c8800583f0b2244cd004b846a1c6445433
Merge happened an hour before that.
Status: RESOLVED → REOPENED
Flags: needinfo?(MattN+bmo)
Resolution: FIXED → ---
Looks like I fixed the problem for Windows 10 but not for Windows 7. Here's another potential fix on try:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=d711334ba5b441d18cd8d42f4937eb2306ec71d6
Flags: needinfo?(MattN+bmo)
Try is all green so far on Windows 7 so I'm retriggering more.
Status: REOPENED → ASSIGNED
This still failed a few times but I'll push it anyways as it can help with a race between the "show" event dispatching and the event listener being added.
Keywords: leave-open
Assignee: MattN+bmo → nobody
Status: ASSIGNED → NEW
Priority: P1 → P2
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7b05d8b4e884
add show event listener immediately after showing in alerts head.js. r=MattN
:mattn, this is still failing quite often on both win10 and win7, could you take another look at this?
Flags: needinfo?(MattN+bmo)
Whiteboard: [stockwell disabled] → [stockwell needswork]
while this is disable-recommended, the failure rate has lowered down over the last 5 days, I don't think we should disable it.
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f170801fe921
Disable browser/base/content/test/alerts/browser_notification_do_not_disturb.js on windows for frequent failures. r=me, a=test-only
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
See Also: → 1411118
closing this bug as a fix to the generic worker resolved issues- any remaining issues with the tests are not related to the worker upgrade.
Status: NEW → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.