The "Optimize Firefox" button in the proposed Perf prefs page should not disable web extensions.

RESOLVED INVALID

Status

()

P3
normal
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: canuckistani, Unassigned)

Tracking

Trunk
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

The main goal of this button is to mitigate any legacy settings or extensions that may be slowing Firefox down. If the button disables extensions, it should exclude web extensions.

TODO: in the future we could monitor reports of slow web extensions and offer to disable those, but this would need to be a data-driven list.
Anything changed since bug 1017919? Can this be done in the proposed schedule given what's said on the bug 1017919?
(In reply to Tim Guan-tin Chien [:timdream] (please needinfo) from comment #1)
> Anything changed since bug 1017919? Can this be done in the proposed
> schedule given what's said on the bug 1017919?

Well, I haven't seen any detailed specs regarding what this button would do, where it would go, what it would affect, etc. Given that, it is not in scope and with reduced availability for most of the team I'm not sure who would work on it. Which schedule/release did you have in mind?
Flags: needinfo?(timdream)
I was referring to Photon schedule in general. It's already being communicated can't reach 55. Just like everything with Photon I would like to help product mgmt figure out feasibility sooner than later. Having an open bug left for the "Reset Firefox" feature look like this is something we'll have to pay special attention to. Thanks.
Flags: needinfo?(timdream)
Whiteboard: [photon-preference]
We are not going to implement this for shipping bug 1329342.
Blocks: 1356269
status-firefox55: affected → ---
No longer depends on: 1329342
Blocks: 1357316
No longer blocks: 1356269
Target Milestone: --- → Firefox 57
QA Contact: hani.yacoub
Flags: qe-verify+
Priority: -- → P3
Target Milestone: Firefox 57 → ---

Comment 6

2 years ago
Pending research results--> ongoing discussion on research team's resource availability
confirmed with UX, not valid anymore
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
Whiteboard: [photon-preference]
You need to log in before you can comment on or make changes to this bug.