Closed Bug 1352848 Opened 5 years ago Closed 5 years ago

Typo fixes around 'settings'

Categories

(Core :: Graphics, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: paul.bignier, Assigned: paul.bignier)

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170323105023

Steps to reproduce:

Found typos around the term "settings"
Attachment #8853773 - Attachment is patch: true
Attachment #8853773 - Attachment mime type: text/x-patch → text/plain
Attachment #8853773 - Flags: review?(MattN+bmo)
Comment on attachment 8853773 [details] [diff] [review]
0001-Typo-fixes-around-settings.patch

Review of attachment 8853773 [details] [diff] [review]:
-----------------------------------------------------------------

Same comments about the commit message apply to this bug too.

::: python/mock-1.0.0/docs/patch.txt
@@ -625,5 @@
>  patch and restore descriptors: class methods, static methods and properties.
>  You should patch these on the *class* rather than an instance.
>  
>  Since version 0.7.0 patch_ and patch.object_ work correctly with some objects
> -that proxy attribute access, like the `django setttings object

According to bug 803654, this an imported file and so it should be changed upstream first, not in mozilla-central.

::: python/mock-1.0.0/html/_sources/patch.txt
@@ +625,5 @@
>  patch and restore descriptors: class methods, static methods and properties.
>  You should patch these on the *class* rather than an instance.
>  
>  Since version 0.7.0 patch_ and patch.object_ work correctly with some objects
> +that proxy attribute access, like the `django settings object

Same here.
Attachment #8853773 - Flags: review?(MattN+bmo) → feedback+
Moving to Graphics since the only remaining fixable issue is there.
Assignee: nobody → paul.bignier
Status: UNCONFIRMED → ASSIGNED
Component: General → Graphics
Ever confirmed: true
Manually requesting review as it appears not to have worked on other patches :S

Regarding the python/ files, my only reference is the tools/rewriting/ThirdPartyPaths.txt list, thanks for pointing out that it is not enough, I will be careful in the future.

Regards,
Paul
Attachment #8853773 - Attachment is obsolete: true
Attachment #8854056 - Flags: review?(MattN+bmo)
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/mozilla-inbound/rev/aa9afbb50505
Fix spelling of 'settings' in comment. r=MattN
Attachment #8854056 - Flags: review?(MattN+bmo) → review+
https://hg.mozilla.org/mozilla-central/rev/aa9afbb50505
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.