Bookmarks from menubar keeps scrolling

RESOLVED DUPLICATE of bug 45700

Status

SeaMonkey
Bookmarks & History
--
minor
RESOLVED DUPLICATE of bug 45700
16 years ago
13 years ago

People

(Reporter: Joshua Goldberg, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031103

I have many pages of bookmarks. If I try to scroll through them from the 
Bookmarks entry of the main menu, the scrolling is unstoppable (although it is
hidable and does not cause any big performance issues.)

Reproducible: Always
Steps to Reproduce:
1. Add many bookmarks
2. Open the bookmarks menu
3. Move the mouse down to the down-arrow
4. Move the mouse back upward (you need to be on the arrow a moment or two to
get this "inertia" effect.)
5. Click on the bookmarks menu again to hide it (but it's scrolling again if you
click a third time to re-reveal.)

Actual Results:  scrolling didn't stop.

Expected Results:  It should stop scrolling when the mouse is taken off the arrow.

(possible enhancements would be an actual scrollbar to make jumping to another
area possible, or hotkeys for jumping by pages, or even typing substrings of
bookmark names to find them.)


while testing this bug I found that the up/down arrow keys, although partially
supported (highlighting the next item in the menu), also do not work properly in
long lists of bookmarks.  similar behaviors ensue, and I also saw it scroll
upward continuously after letting go of the held down-arrow key.  I don't have
time right now to make a full report of that separately.

It is conceivably (but probably not) relevant that I do have some (but not many
or very nested) submenus in my large collection of bookmarks.

Comment 1

16 years ago
This still exists in 1.0RC1 on Linux (SuSE 7.3). It's pretty annoying, as my
list is so long that I cannot access the bookmarks in the middle any more - the
scrolling won't stop till it has reached either end. Since I don't usually use
the Sidebar (takes too much screen space) I wouldn't call it minor.

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 45700 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
This is not a duplicate (I have been quite interested in both this and the
oringinal for quite some time)

I am using OSF/1 on alpha, and can verify this behaviour for 1.1b (but don't use
that out of choice for many other reasons)

Going to the arrow at the top of the menu when the bottom half of your bookmarks
is shown will scroll upwards, but when you move the mouse down off the arrow
slightly it should stop scrolling. It doesn't always - randomly it keeps going
until it hits the top of the bookmarks.

Is this related to another problem I am seeing - Moving the mouse from one
folder that is opened down to the next, often closes the first folder, but
doesn't open the second, until I move the mouse by 1 pixel?

Comment 4

16 years ago
Stupid me. s/1.1b/1.1a/

There is no 1.1b binary yet for tru64.....
(Reporter)

Comment 5

15 years ago
Having upgraded to 1.3b (Solaris, BuildID 2003021104) I wanted to update that
the same bug still exists.  Once the bookmark list starts scrolling, it is
uncontrollable (with cursor-keys, and/or moving the mouse back off the arrows.)
 The escape-key or clicking the mouse do succeed in getting the menu to go away
so the whole browser session is not lost.

I would put this under 45700, but that seems to deal more with the issue of
whether the scrollbar is the right UI component, as opposed to a bug in that
component.  Sorry if I'm misinterpreting.  I do suggest this one be reopened.
(Reporter)

Comment 6

15 years ago
I just found some bugs under "XP Toolkits/Widgets: Menus" that I do think should
be merged with this one.  This is probably a duplicate of bugs # 124243 and
51004 (Those two haven't been marked as co-duplicates of each other, either.)


Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.