bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[Regression] Activity stream - top sites issues

RESOLVED FIXED

Status

()

Firefox for iOS
General
P2
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: isabel_rios, Unassigned)

Tracking

({regression})

unspecified
Other
iOS
regression
Dependency tree / graph

Firefox Tracking Flags

(fxios8.0+)

Details

(Whiteboard: [mobileAS])

Attachments

(5 attachments)

(Reporter)

Description

a year ago
Created attachment 8853901 [details]
topsites1.png

Master build 58ededc6e2a534df3b2d77883319346774fb1da3

XCUITests covering AS are failing:
https://dashboard.buddybuild.com/apps/57bf25c0f096bc01001e21e0/build/58e04d19c4ac6f0001d4a25f#tests

It is also possible to reproduce manually on simulator (iphone 6 10.2) and ipod touch (10.2) these issues:

- More than 6 top sites are shown, so the control page button does not appear when it should. Please see screenshots attached. It is necessary to add more than 4 sites so that there are more than 9 top sites and the view when tapping on control button is broken.

- Long press on a top site to open it in private mode is not working. Long pressing on the site opens the context menu, but when tapping on Open in New Private Tab option nothing happens

Investigating why the other tests fails. The error is in the assertion when trying to count and compare the sites that there should be. But seems that the problem is that it is not possible to access them. 
Looking at the logs (attached), it seems that app.tables["Top sites"] is not defined.

Changing these lines:

let topSites = app.tables["Top sites"].cells["TopSitesCell"]
let numberOfTopSites = topSites.children(matching: .other).matching(identifier: "TopSite").count

With these ones: 
let topSites = app.cells["TopSitesCell"]
let numberOfTopSites = topSites.cells.matching(identifier: "TopSite").count

Make the tests pass locally. 
Not sure if that is the cause. It is strange because going back to a commit where these tests passed in the past, I can reproduce this issue now locally.
(Reporter)

Comment 1

a year ago
Created attachment 8853903 [details]
topsites2.png
(Reporter)

Comment 2

a year ago
Created attachment 8853904 [details]
topsites3.png
(Reporter)

Comment 3

a year ago
Created attachment 8853905 [details]
topsites4.png
(Reporter)

Comment 4

a year ago
Created attachment 8853906 [details]
TopSitesLogs.rtf
(Reporter)

Comment 5

a year ago
Could you confirm whether there has been a change here so that we have to update the tests? 
And also about the regressions to confirm if they are bugs.

Thanks!
Flags: needinfo?(fpatel)
Yea we changed the Topsites. Some of these regressions are already fixed in a patch I have waiting for review. While the tests specifically I'll fix once changes to the UI stop.
Flags: needinfo?(fpatel)
(Reporter)

Comment 7

a year ago
Thanks! Let me know if you want me to open separate bugs for the different issues or it is fine having them here.
Also, about the tests, I can fix them if you want once the UI work finishes.
(Reporter)

Updated

a year ago
Blocks: 1352967
(Reporter)

Updated

a year ago
Blocks: 1353047
Iteration: --- → 1.19
tracking-fxios: ? → 8.0+
Priority: -- → P2
(Reporter)

Updated

a year ago
Blocks: 1353432
(Reporter)

Comment 8

a year ago
There is a new issue with the new AS (bb 2674 commit: 02467f8):

- Long tapping on a top site and selecting Share does not open the Share menu.

Also one question, should the empty placeholders for new top sites be shown? For example now as default there are five top sites and it is possible to see 3 placeholders for the new top sites' icons. Is that correct?

As AS is an ongoing work you are probably aware of this, but if not and need a bug for it, please let me know.

Thanks!
Flags: needinfo?(fpatel)
That looks like a bug. The share menu doesnt seem to work at all.
Flags: needinfo?(fpatel)
PS. I'm not usually aware of every bug :) Filling a bug is usually a good call. If its a dupe/invalid we can always close it. But at least then it wont get lost in a comment. And someone else can pick it up if I don't get a chance.
(Reporter)

Comment 11

a year ago
Thanks! Already filed a bug 1357108 for that.

And yeah, I know, sorry, just wanted to avoid creating a bug that you were already working on :)
(Reporter)

Updated

a year ago
See Also: → bug 1357108
Whiteboard: [mobileAS]
I think all the regressions mentioned in this bug are fixed. We could open a new bug for fixing the Activity Stream tests. 

I'm going to close this bug.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Reporter)

Comment 13

a year ago
Thanks Farhan, there is already a bug for re-enabling those tests. That is bug 1353432
(Reporter)

Comment 14

a year ago
There is one of the issues mentioned that is not fixed yet, at least I can still reproduce:
iOS 6 simulator 10.3, commit: 141e476b0b25e1a430cb6599ee22bba0af33f353

- Long press on a top site to open it in private mode is not working. Long pressing on the site opens the context menu, but when tapping on Open in New Private Tab option nothing happens.

I will open a follow up bug for that.
(Reporter)

Updated

a year ago
See Also: → bug 1358416
You need to log in before you can comment on or make changes to this bug.