MSN/JavaScript. Pressing the "Yes, I Agree" button does not give the expected result.

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: bugs, Unassigned)

Tracking

({top100})

Trunk
x86
All
top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/00200203
BuildID:    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/00200203

In the MSN Communities, adult communities are protected by an agreement page
(full of legal mumbo-jumbo) that makes you click "Yes, I Agree" before you are
allowed to visit the community. 

In other browsers (for example, Opera version "6.0 Technology Preview 3" build
"098"), getting past this page works as expected. In Mozilla, pressing the "Yes,
I Agree" button just seems to refresh the current page as opposed to redirecting
you to the desired community page.

This may be a Tech Evangelism issue as MSN may be doing something that's not in
line with current standards upheld by Mozilla. I just thought I'd bring it to
your attention since Opera (as well as Windows based IE6 and Netscape) worked.


Reproducible: Always
Steps to Reproduce:
1.Go into Mozilla's preferences and make sure JavaScript is enabled for the
browser and put checks in all the boxes under "Allow Webpages To:".

2. Go to the URL indicated (http://communities.msn.com/mozillatest).

3. You may need to sign in with a hotmail account. 

4. Once the agreement page has loaded, click on the "Yes, I Agree" button and
see what happens.


Actual Results:  The current "agreement" page seems to be refreshed (the ads on
the borders change, etc.), but no redirect happens.

Expected Results:  We should have been redirected to the community page.
(Reporter)

Comment 1

16 years ago
I've just tested this on Galeon 1.2.0 as well and it properly redirects past the
agreement page to the community.

Comment 2

16 years ago
I bet ten cookies that you have cookies off.
(Reporter)

Comment 3

16 years ago
Unfortunately, no. I've tried it with the Cookies settings at "Enable cookies 
for the originating web site only" as well as "Enable all cookies" and I get 
the same result.

I only have one machine here that's running Linux so I can't confirm that it's 
not just my installation of Mozilla (or the installation of something Mozilla 
depends on). So, if this bug isn't a bug for anyone else, feel free to tell me 
to go away. 
:)

Comment 4

16 years ago
confirm in mozilla and commercial from 2002 04 02 on win2k. -> OS = all
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Mass-reassigning bugs to dom_bugs@netscape.com
Assignee: jst → dom_bugs

Comment 6

14 years ago
I created the http://groups.msn.com/MozillaTest group, made it adult and
invitation only. I was able to accept the adult terms, invited another account,
posted messages with attachments, moderated etc.

fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: top100
Resolution: --- → FIXED

Comment 7

14 years ago
->WORKSFORME
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

14 years ago
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.