[RFE] "Save State" option for saving/reinstating URLs in a tabbed window

VERIFIED DUPLICATE of bug 119599

Status

SeaMonkey
Tabbed Browser
--
enhancement
VERIFIED DUPLICATE of bug 119599
16 years ago
9 years ago

People

(Reporter: cooperg, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
This is a request for enhancement on a 'Save State' option for the current 
window. This would save a config file in Bookmarks that would, when activated, 
open up whatever URLs (*including pages in tabs*) you had open 
at the time you requested the Save State. 

I would suggest making the config file a separate file and not just part of
bookmarks.html so that the file could be transferred easily. This could be
done by having a Save State directory with the user preferences and have in
Bookmarks a link similar to the one used for "Imported IE Favorites" for the
Save States directory. My reasoning for desiring this to be in a file and 
not part of bookmarks.html is explained in the 'primary usage' below.

Primary usage of the feature:

Let's say you're job hunting. You go to dice and ctrl-click on the job desc's
and you quickly have 20 different tabs open in your window, each full of 
opportunity. Before you can go through them all, however, you need to switch 
computers (you might have started in a computer lab or somesuch, or instead
of jobsearching, doing research at work and want to take it home). So you do 
this Save State option, email it to yourself, and when you get home you just 
open the config file in Moz and voila! Your research is reinstated!

Secondary usage of the feature:

Let's say you travel to several websites every morning when you get to work.
Mozdev, slashdot, cnn, etc. This config file would pop up your favorite URLs,
each in its own neat little tab for your perusal, all with one click. 
Pretty sweet, eh?

Comment 1

16 years ago
We've already got this feature, it's called Bookmark Groups.  Opena  bunch of 
tabs, then go to Bookmakrs->Add Bookmark and check the "Bookmark Groups" 
option.

*** This bug has been marked as a duplicate of 119599 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.