TB crashes upon ExQuilla connection

RESOLVED INVALID

Status

Thunderbird
Account Manager
--
critical
RESOLVED INVALID
11 months ago
8 months ago

People

(Reporter: anfire, Unassigned)

Tracking

({crash})

52 Branch
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addon:exquilla], crash signature)

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170330120906

Steps to reproduce:

I opened TBird and it automatically connected to search for messages. ExQuilla hadn't worked for a while and, suddenly, it worked and tried to connect.


Actual results:

A crash window opened telling me TBird has closed unexpectedly, even though it hadn't. After that, it seemed like every time ExQuilla connected, the same crash window would appear.


Expected results:

Regular connection. When I switched the account to manual, the crash stopped, but it'll come back when I force-update the account to get new emails.

Updated

11 months ago
Severity: normal → critical
Keywords: crash

Comment 1

11 months ago
Rkent, can you check if this is an ExQuilla problem or core TB?
Flags: needinfo?(rkent)

Comment 2

11 months ago
You're using the new ExQuilla version for TB 52, right?

Comment 3

11 months ago
User is Mac. So crash might be [@ libsystem_kernel.dylib@0x19d42 ] which a small spot check shows most have exquilla like bp-1c7a1491-5531-410f-beec-2c3ba2170409 (exquilla 52.0.1174)

bp-9d9f5985-e3f3-4ad1-9fe0-95f362170411 appears to be an exception - no exquilla
Status: UNCONFIRMED → NEW
Crash Signature: [@ libsystem_kernel.dylib@0x19d42 ]
Ever confirmed: true

Comment 4

10 months ago
A week ago I could reproduce this easily using an Exchange account that used NTLM. Today, not. There was an OS update in the interim. I wonder if there was an OSX fix that got rid of this? The crash was in the OSX system coded.
Flags: needinfo?(rkent)

Comment 5

10 months ago
Just to let you know;
https://support.mozilla.org/en-US/questions/1157611
User reports Firefox crashed.

This bug was shown in the Related Bugs list

https://crash-stats.mozilla.com/report/index/82bd1c0b-7088-4c36-bfb6-0bc3c1170424

Comment 6

10 months ago
User reports; Thanks for the suggestion, but no, I'm not using nor ever used it.

Comment 7

9 months ago
Anfire, do you still crash?


(In reply to Kent James (:rkent) from comment #4)
> A week ago I could reproduce this easily using an Exchange account that used
> NTLM. Today, not. There was an OS update in the interim. I wonder if there
> was an OSX fix that got rid of this? The crash was in the OSX system coded.

Dramatic reduction in crash rate, near zero, since 10.12.4 is gone. What's left are a few 10.12.5 and 10.12.6. A few examples. Maybe half have exquilla
bp-0971ff33-dc8a-4898-b715-862300170522
bp-4157d7c6-6f4d-4a2f-9e5b-400f60170521
bp-049f27af-85b4-4d76-8a1b-a42b30170521
Flags: needinfo?(anfire)
Whiteboard: [closeme 2017-06-01]
(Reporter)

Comment 8

9 months ago
Hey all,
Thanks for following up on this! Up till today, I was using TB 53 but just updated to version 54 (so 54.0b1). Both versions crash right at start-up. As I had described, a crash report window pops up but TB actually works (expect for the Exchange account, of course) so I usually leave TB open and simply try not to restart it. As for the pop-up window, I just close it since I don't want to either quit or relaunch TB. One more thing: after the crash report window, I get another tiny window asking me for authentication for the Exchange account. Invariably, it adds "undefined" before my user name. Say my server user name is "Anfire" and the server name is "FIRE", the window will display "undefinedFIRE\Anfire" as User name. The password is already entered so I delete "undefined" and click "ok". A while ago, this would be followed by another tiny window asking for my account password but that has since stopped.
I hope this clears things up a bit. Any way to get Exchange support natively some day?
Best,
Anfire

Here is the most recent crash report: https://pastebin.com/KMmnRqkB
Flags: needinfo?(anfire)

Comment 9

8 months ago
>  Any way to get Exchange support natively some day?
Not in the current era

You're only recourse here is to have a fixed exquilla addon
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → INVALID
Whiteboard: [closeme 2017-06-01] → [addon:exquilla]
You need to log in before you can comment on or make changes to this bug.