No icon displayed for “disallow Script Button” add-on

RESOLVED WONTFIX

Status

()

Firefox
Extension Compatibility
RESOLVED WONTFIX
a year ago
4 months ago

People

(Reporter: Vasilica Mihasca, QA [away for an extended period of time - please needinfo addonsqa@softvision.ro], Unassigned)

Tracking

({regression})

Trunk
All
Windows 10
regression
Points:
---

Firefox Tracking Flags

(firefox52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 fix-optional)

Details

Attachments

(1 attachment)

[Affected versions]:
Firefox 55.0a1 (2017-04-04)


[Affected platforms]:
Windows 10 64-bit
Ubuntu 16.04 32-bit

[Steps to reproduce]:
1.Launch Firefox with a clean profile.
2.Install the following add-on: https://addons.mozilla.org/en-US/firefox/addon/disallow-script-button/?src=search

[Expected Results]:
“disallow Script Button” icon is successfully displayed in toolbar/Panel Menu/Customisation Panel.

[Actual Results]:
There is no icon displayed for “disallow Script Button” add-on.


[Regression Range]:
Last good revision: 200182ef115692c4ed2909f1a8beae8a6f19d127
First bad revision: 65a83a84898ec3486aa36065d0f62f16c9a5b25d
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=200182ef115692c4ed2909f1a8beae8a6f19d127&tochange=65a83a84898ec3486aa36065d0f62f16c9a5b25d
Created attachment 8857084 [details]
Browser Console Error

I see an XML Parsing Error: undefined entity location error in the browser console when trying to install.
Vasilica, would it be possible to run mozregression again? The only thing remotely close to addons is:

> Kris Maglione — Bug 1335180: Fix race in browser_ext_tabs_reload_bypass_cache. r=mixedpuppy

But that just fixes a test (...for webextensions).
Flags: needinfo?(vasilica.mihasca)
(In reply to Mike Taylor [:miketaylr] from comment #2)
> Vasilica, would it be possible to run mozregression again? 
 
Performed again but I received the same result. That's all I can get from mozregression. The tool stops because there are no more inbound revisions. 

Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=200182ef115692c4ed2909f1a8beae8a6f19d127&tochange=65a83a84898ec3486aa36065d0f62f16c9a5b25d
Flags: needinfo?(vasilica.mihasca)
Andy, would you be able to find someone to look at the regression range to identify what could have caused an XML Parsing error in an overlay.xul file? Thanks!
Flags: needinfo?(amckay)

Comment 6

a year ago
I'd rather people focus on WebExtensions, rather than a XUL overlay add-on with that number of users. Is there some reason we should take the time to look at this?
Flags: needinfo?(amckay)
Nope, that's fair.
status-firefox55: affected → fix-optional
Mass-closing old Extension Compatibility bugs that relate to legacy add-ons or NPAPI plug-ins. If you think this bug is still valid, please reopen or comment.

Sorry for the bug spam, and happy Friday!
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.