Synced devices hung or throbber continually shown (devices with tabs shown however)

RESOLVED WORKSFORME

Status

()

Firefox for iOS
Sync
P2
normal
RESOLVED WORKSFORME
7 months ago
6 months ago

People

(Reporter: aaronmt, Unassigned)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios8.0+, fxios-v7.0 affected)

Details

(Whiteboard: [MobileCore])

(Reporter)

Description

7 months ago
=> Launched Firefox after installing 7.0 
=> Signed in to Sync
=> Tapped the History panel, tapped Synced devices (2 devices shown)
=> See a loading throbber that does not go away

Both devices are shown with tabs however
Please investigate some scenarios as to what's happening when pulling down to refresh.
tracking-fxios: ? → 8.0+
Flags: needinfo?(catalin.suciu)
Priority: -- → P2
Whiteboard: [MobileCore]
(Reporter)

Comment 2

7 months ago
This seems to work fine for me on master.

Comment 3

7 months ago
I am unable to reproduce this issue following the steps from the description. 

I am seeing something similar on an iPad Air 2 / iOS 10.3 on 7.0(2330) and Nightly #2396. The spinner will remain on the screen after following the below STR:

1. Launch Firefox
2. Sign in to Sync
3. Tap History panel
4. Tap Synced devices 
5. Pull down to refresh the list (Do not release the finger while the spinner is displayed)
6. Tap home button 
7. Restore Firefox

Actual results: 
- The spinner will be displayed and will not go away only after performing another refresh on the list or Firefox will Sync.

See a video here: https://www.youtube.com/watch?v=COds1rn1kO8
(Reporter)

Comment 4

6 months ago
Tried again today with release and it works for me on my home network.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WORKSFORME
I noticed this today when waking my iPad after it hadn't synced for a couple of days. The throbber is visible so long as the device is syncing, and while the throbber is visible you can't scroll the list. In my case that was about 45 seconds, which was kinda annoying.

I wouldn't mind reopening this bug and having the throbber only 'link' to a sync if you pulled to refresh. Background syncs are a normal occurrence and shouldn't affect this kind of UI.
(In reply to Stephan Leroux [:sleroux] from comment #1)
> Please investigate some scenarios as to what's happening when pulling down
> to refresh.

Pull to refresh does not initiate a sync.
https://bugzilla.mozilla.org/show_bug.cgi?id=1355085

Synced devices list appears empty after backgrounding/foregrounding the app while sync is in progress.
https://bugzilla.mozilla.org/show_bug.cgi?id=1354466
     
Synced devices list can't be scrolled while the loading throbber is displayed. 
https://bugzilla.mozilla.org/show_bug.cgi?id=1353377#c5
Flags: needinfo?(catalin.suciu)
You need to log in before you can comment on or make changes to this bug.