Add pref to always open a new tab next to the current one to SeaMonkey

RESOLVED FIXED in seamonkey2.60

Status

enhancement
RESOLVED FIXED
2 years ago
9 months ago

People

(Reporter: michaelaccountsly, Assigned: ben)

Tracking

(Blocks 1 bug)

unspecified
seamonkey2.60
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.49esr fixed, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.60 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

2 years ago
+++ This bug was initially created as a clone of Bug #528005 +++

With many tabs, FF currently opens links or new tab somewhere at the far end of all tabs. Especially for links that are related to the current page, that's very inconvenient as user needs to drag newly opened tab all the way back to place it beside the current tab. There should be some way of opening links/new tabs right next to the current tab.

As implemented in FF, this was done as a modifier-click on the "+" button that adds a tab; I would greatly prefer that this be implemented as a preference, so that command-T in Mac OS and its Windows equivalent could be set to open the new tab to the right by default.
Reporter

Comment 1

2 years ago
(Looking at the part quoted in OP from  Bug #528005, I'm actually fine with the current behavior when one clicks on a link: in both FF and SM, one has the option of letting right-clicked links open immediately to the right. But I would definitely like to be able to set it so that wholly new tabs would also open to the right, whether opened with command-click or with the "New Tab" button).

Comment 2

2 years ago
I agree, opening a new tab next to the current one via CTRL+T keyboard shortcut would be very convenient. It doesn't need to be the default behavior, it could be controlled through a preference such as browser.tabs.insertNewAfterCurrent (as suggested in <https://bugzilla.mozilla.org/show_bug.cgi?id=528005#c18> 7 years ago).

Comment 3

Last year
Same here. After > 7 years of waiting, please make this happen.
Assignee

Comment 4

11 months ago
I have found a way how this can be solved easily.

There will be a new preference "browser.tabs.insertAllTabsAfterCurrent": default = false.

If "browser.tabs.insertAllTabsAfterCurrent" = true, then all new tabs are inserted in the same way.
If "browser.tabs.insertRelatedAfterCurrent" = false, then all new tabs are insert at the end, just like before.
If "browser.tabs.insertRelatedAfterCurrent" = true, then all new tabs are insert right next to the current tab.

All means: 
open a link in new tab, 
open a new tab with the "New Tab" button, 
open a new tab via CTRL+T keyboard shortcut,
tab is opened from an external application or bookmark or ....
Assignee

Updated

11 months ago
Assignee: nobody → bschwarze
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → seamonkey2.53
Assignee

Comment 5

11 months ago
Hi Frank, can you please take over these two lines in SM2.53

browser-prefs.js:

+ pref("browser.tabs.insertAllTabsAfterCurrent", false);

tabbrowser.xml Line 1685:

- if ((aRelatedToCurrent || aReferrerURI) && this.mPrefs.getBoolPref("browser.tabs.insertRelatedAfterCurrent")) {

+ if ((aRelatedToCurrent || aReferrerURI || this.mPrefs.getBoolPref("browser.tabs.insertAllTabsAfterCurrent")) &&   this.mPrefs.getBoolPref("browser.tabs.insertRelatedAfterCurrent")) {

These two lines make it easier for many people who use many tabs.

If you do not change the prefs, the behavior of SM does not change.
if you change browser.tabs.insertAllTabsAfterCurrent to true under about:config, every new tab will be added right next to the current tab.
Flags: needinfo?(frgrahl)
This should work but why don't you just add a patch and asking for review?

I reset the flags. target is only set  to the current version (2.60 now) after review and checkin. This is an old enhancement bug. If the patch gets r+ we should decide later in which to push it. Might well go into a future 2.49 too. No l10n changes here.
Flags: needinfo?(frgrahl) → needinfo?(bschwarze)
Target Milestone: seamonkey2.53 → ---
Assignee

Comment 7

10 months ago
Do I have to install Mercurial to upload the patch?
Is there an easy way to add a small patch?
Flags: needinfo?(bschwarze) → needinfo?(frgrahl)
Assignee

Comment 8

10 months ago
Posted patch patch-1353428.diff (obsolete) — Splinter Review
I hope the format of the patch is correct.
Flags: needinfo?(frgrahl)
Attachment #8999474 - Flags: review?
Comment on attachment 8999474 [details] [diff] [review]
patch-1353428.diff

Sorry I am a bit busy this week. Might manage Thursday.

The patch is missing a correctly formatted header. If you install at least mozilla-build 3.2 and Tortoise Hg you could use Mercurial queues which makes life much easier if you plan to dive into the code.
Attachment #8999474 - Flags: review? → review?(frgrahl)
bblack, I reformatted the patch and tested it in both 2.53 and 2.57. Wasn't aware that you just diffed the unpacked source until I tried to appy it. I am asking IanN for a final review because it introduces some new functionality via a pref.

f+ from me.

If you do other patches please install mercurial.
Attachment #8999474 - Attachment is obsolete: true
Attachment #8999474 - Flags: review?(frgrahl)
Flags: needinfo?(bschwarze)
Attachment #9002254 - Flags: review?(iann_bugzilla)
Attachment #9002254 - Flags: feedback+
Attachment #9002254 - Flags: approval-comm-esr60?

Comment 11

10 months ago
Comment on attachment 9002254 [details] [diff] [review]
1353428-newtab.patch

r/a=me
Attachment #9002254 - Flags: review?(iann_bugzilla)
Attachment #9002254 - Flags: review+
Attachment #9002254 - Flags: approval-comm-esr60?
Attachment #9002254 - Flags: approval-comm-esr60+

Comment 12

10 months ago
As the patch doesn't quite add the functionality in the subject, can the subject be amended and a follow-up bug spun off?

Comment 13

10 months ago
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/7fc7bd15790d
Add option to open new tabs always next to the current one. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Flags: needinfo?(bschwarze)
Target Milestone: --- → Future
Summary: Let accel-click and middle-click on the new tab button open a new tab next to the current one → Add pref to always open a new tab next to the current one to SeaMonkey
Blocks: 1487519
Comment on attachment 9002254 [details] [diff] [review]
1353428-newtab.patch

Works fine in 2.53 and just needs a mini rebase for the prefs for 2.49 so I think lets take it to 2.49.5
Attachment #9002254 - Flags: approval-comm-esr52?
comm-central is still 2.60
Target Milestone: Future → seamonkey2.60

Comment 16

10 months ago
Comment on attachment 9002254 [details] [diff] [review]
1353428-newtab.patch

a=me
Attachment #9002254 - Flags: approval-comm-esr52? → approval-comm-esr52+
You need to log in before you can comment on or make changes to this bug.