Fix opengraph image links that point to old logo - update to new logo

RESOLVED FIXED

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: supnah, Assigned: kohei)

Tracking

(Blocks: 1 bug)

Production

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
I've been tracking down why the old logo appears in the email collection form on this page: https://medium.com/@mozilla/hackers-trackers-and-snoops-our-privacy-survey-results-1bfa0a728bd5#.6c5e618mi

Finally tracked it down to embedly pulling from the opengraph data here: https://www.mozilla.org/en-US/newsletter/mozilla/

Which is pointed at this image: content="https://www.mozilla.org/media/img/mozorg/mozilla-256.c29a8b01d659.jpg"

So the small ask is to update this page to have the opengraph data point at an updated logo.

The larger ask is to do a check and make sure we've reviewed all of our opengraph links and ensure we're pointing at the new logo.

I would not put this particular page as hyper critical, so if time is better spent doing a fix-once for everywhere solution, that's totally fine, unless that's going to take a long time, in which case it would be great to get the identified page (https://www.mozilla.org/en-US/newsletter/mozilla/) updated first.

Once it's updated we'll need to ping Medium and have them refresh on their end to pull the new logo, but this is possibly affecting a lot of other things that we just haven't identified yet.
(Reporter)

Updated

2 years ago
Flags: needinfo?(erenaud)
We're discussing this, how best to replace the image along with trying to determine what needs to be done on the medium side to update (it's in doubt whether they cache, so replacing the image in the cdn with the same file name, then refreshing the cdn, may be all that's required, if I'm understanding correctly).
Blocks: 1333244
Flags: needinfo?(erenaud)
Yuliya - could you please have someone in Creative provide a suitable replacement in the new brand font (.jpg w. roughly same size - 5.2kb and dimensions) for this logo image and have them upload it to this bug?

The image needing replacement is:
https://www.mozilla.org/media/img/mozorg/mozilla-256.c29a8b01d659.jpg
Flags: needinfo?(ygorlovetsky)
(Reporter)

Comment 3

2 years ago
Medium will do a cache refresh when we tell them we've updated the image. It may or may not be necessary, but they said they'd be happy to do it to make sure the update goes through asap. I have an open ticket with Medium support where I can easily request this. Feel free to ping me when we are ready to do that.

Comment 4

2 years ago
(In reply to Eric Renaud from comment #2)
> Yuliya - could you please have someone in Creative provide a suitable
> replacement in the new brand font (.jpg w. roughly same size - 5.2kb and
> dimensions) for this logo image and have them upload it to this bug?
> 
> The image needing replacement is:
> https://www.mozilla.org/media/img/mozorg/mozilla-256.c29a8b01d659.jpg

Adding Michael Ham. Michael, will you please mock this up. Please ping Brad if you have any questions. Thanks.
Flags: needinfo?(ygorlovetsky) → needinfo?(mham)

Comment 5

2 years ago
Created attachment 8864938 [details]
moz_logo-BW_opengraph.jpg

JPEG at 256px x 256px for Opengraph/Medium
Flags: needinfo?(mham)

Comment 6

2 years ago
Created attachment 8864939 [details]
moz_logo-BW_opengraph.png

PNG version of Mozilla logo at 256px x 256px for Opengraph/Medium

Comment 7

2 years ago
Created attachment 8864940 [details]
moz_medium_mock-up.jpg

Mock up view of logo in-page on Medium.
Created attachment 8865764 [details] [review]
pull request
Assignee: nobody → kohei.yoshino
Status: NEW → ASSIGNED

Comment 9

2 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/5b9515bea993c791bab1f175963b49dc3a812886
Fix Bug 1353454 - Fix opengraph image links that point to old logo - update to new logo

https://github.com/mozilla/bedrock/commit/8333e6ef84b9f274a367c2458ab676626cc54db4
Merge pull request #4817 from kyoshino/bug-1353454-update-ogp-logo

Fix Bug 1353454 - Fix opengraph image links that point to old logo - update to new logo

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

2 years ago
Is this ready for me to ask medium to refresh, or are there more steps required?
Brad - that update logo image is live, freely accessible. Just be sure to note the file location when asking medium as it does not resolve to the same URL.

New URL - https://www.mozilla.org/media/img/mozorg/mozilla-256.4720741d4108.jpg

And a big thanks to Kohei for submitting the PR,the contribution is always appreciated.
Flags: needinfo?(bcohen)
(Reporter)

Comment 13

2 years ago
This has been refreshed by the Internet Citizen channel (thanks to Kevin Zawacki), and is now live and correct. This bug can be closed I think. Is there anything else we need to do to help make sure people from across the org point at the right thing in the future? Any other actions to take?
Flags: needinfo?(bcohen)
You need to log in before you can comment on or make changes to this bug.