Closed Bug 1353564 Opened 4 years ago Closed 2 years ago

Add stepping and resume buttons to the PausedDebuggerOverlay

Categories

(DevTools :: Debugger, enhancement, P5)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1565375

People

(Reporter: pbro, Unassigned)

References

(Blocks 2 open bugs)

Details

Bug 1338582 introduces a new highlighter that displays an overlay on top of the page and a message to users. The aim is to use this when the debugger is paused.

The goal of this follow-up bug is to also implement the buttons as described in bug 1338582 comment 0 and as shown in this screenshot: https://cloud.githubusercontent.com/assets/2134/22383567/2ffd2ce6-e47f-11e6-984b-d3f5a0ac2e53.png

See some thoughts about implementation in bug 1338582 comment 5, repeated here for simplicity:

Some ideas about how to implement the step/resume buttons:

We could simply pass a new option to the show method:

overlay.show(toolbox.walker.rootNode, {
  threadActor: toolbox.threadClient._actor
});

Then, in the show method implementation, in the highlighter, we could retrieve the thread actor like so:

let threadActor = this.env._tabActor.conn.getActor(options.threadActor);

Now, using this actor, we could resume: threadActor.onResume(); or do other things.

What I don't know yet is: will the debugger front-end just know that we stepped over/in/out or resumed? We're basically using the threadActor on the server, so not initiating the action from the front-end. So the front-end will need to know that this happened.

There is also a problem: when the script execution is paused, all events are blocked. This is how the debugger works. But that also means that clicking on a resume button that is inside the page (because that's how highlighters work, they are injected in the page) won't work!
This might be solvable with bug 1177346.
Product: Firefox → DevTools
Severity: normal → enhancement
Priority: -- → P3
Depends on: 1354679
Priority: P3 → P5
Blocks: 1565711
Blocks: 1565713
No longer blocks: 1565711
No longer blocks: 1565713
No longer depends on: 1354679
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1565375
You need to log in before you can comment on or make changes to this bug.