Make GetNextExternalImageId() as to use GetNextResourceId()

RESOLVED DUPLICATE of bug 1358014

Status

()

Core
Graphics: WebRender
RESOLVED DUPLICATE of bug 1358014
8 months ago
7 months ago

People

(Reporter: sotaro, Assigned: sotaro)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 months ago
This bug is preparation of Bug 1345054. To support video pipeline, WebRenderImageLayer needs to allocate pipeline id. But current WebRenderBridgeParent uses LayersId as PipelineId and it is allocated by GPUProcessManager.

To support video pipeline, we need to split PipelineId and LayersId.
(Assignee)

Updated

8 months ago
Blocks: 1345054
(Assignee)

Comment 1

8 months ago
Another way to address the problem is use name space that is not used by LayersId.
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Comment 2

8 months ago
(In reply to Sotaro Ikeda [:sotaro] from comment #1)
> Another way to address the problem is use name space that is not used by
> LayersId.

It seems better approach, since video pipeline might be removed when WebRender supports partial list update.
(Assignee)

Updated

8 months ago
Summary: Split PipelineId and LayersId → Make GetNextExternalImageId() as to use GetNextResourceId()
(Assignee)

Comment 3

8 months ago
Created attachment 8854718 [details] [diff] [review]
patch - Make GetNextExternalImageId() as to use GetNextResourceId()
(Assignee)

Comment 4

8 months ago
With attachment 8854718 [details] [diff] [review], ExternalImageId do not conflict with PipelineId, since PipelineId.mNamespace is 0 and ExternalImageId's mNamespace is not 0.
(Assignee)

Comment 5

8 months ago
With attachment 8854718 [details] [diff] [review], ExternalImageId could be used for PipelineId of Async video.
(Assignee)

Comment 6

8 months ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f19da5797f57f3de480ca263dc6b73ae9039f030
(Assignee)

Updated

8 months ago
Attachment #8854718 - Flags: review?(jmuizelaar)
(Assignee)

Updated

8 months ago
Attachment #8854718 - Flags: review?(jmuizelaar)
(Assignee)

Comment 7

7 months ago
This bug is replaced by bug 1358014.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1358014
You need to log in before you can comment on or make changes to this bug.