Closed Bug 1353649 Opened 3 years ago Closed 3 years ago

Update to tzdata2017b

Categories

(Core :: JavaScript: Internationalization API, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox-esr52 --- fixed
firefox53 --- fixed
firefox54 --- fixed
firefox55 --- fixed

People

(Reporter: anba, Assigned: anba)

Details

Attachments

(1 file)

Update the tzdata info for ICU to tzdata2017b.
Attached patch bug1353649.patchSplinter Review
Generated with:
  cd intl
  ./update-tzdata.sh -e $ICU58_BUILD_DIR/bin/icupkg 2017b
  cd ../js/src/builtin
  ./make_intl_data.py tzdata


Updates:
- Haiti (America/Port-au-Prince) uses daylight saving time this year.
Attachment #8854869 - Flags: review?(jwalden+bmo)
Attachment #8854869 - Flags: review?(jwalden+bmo) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/391a1e1b1698
Update tzdata in ICU data files to 2017b. r=Waldo
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/391a1e1b1698
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Probably should start the backporting fun, woo.
Comment on attachment 8854869 [details] [diff] [review]
bug1353649.patch

Approval Request Comment
[Feature/Bug causing the regression]: N/A

[User impact if declined]:
Wrong or inconsistent time zone data when calling methods from Intl.DateTimeFormat or methods internally using Intl.DateTimeFormat (that means Date.prototype.toLocale(Date|Time)String()). Inconsistencies are possible when the OS already uses the current tzdata release (tzdata 2017b), but our internal ICU version still uses tzdata 2017a. 
Based on the release notes for tzdata 2017b (http://mm.icann.org/pipermail/tz-announce/2017-March/000046.html), the update is of special interest for Haitian users (Haiti resumes observing DST).

[Is this code covered by automated tests?]:
Yes.

[Has the fix been verified in Nightly?]:
Yes.

[Needs manual test from QE? If yes, steps to reproduce]: 
No.

[List of other uplifts needed for the feature/fix]:
None.

[Is the change risky?]:
No.

[Why is the change risky/not risky?]:
It only updates time zone data files.

[String changes made/needed]:
No.
Attachment #8854869 - Flags: approval-mozilla-beta?
Attachment #8854869 - Flags: approval-mozilla-aurora?
Comment on attachment 8854869 [details] [diff] [review]
bug1353649.patch

We can just squeak this into 53 - It would be good to land this on m-b before tomorrow's merge and RC build. If it doesn't land before the merge please request uplift to mozilla-release.
Attachment #8854869 - Flags: approval-mozilla-beta?
Attachment #8854869 - Flags: approval-mozilla-beta+
Attachment #8854869 - Flags: approval-mozilla-aurora?
Attachment #8854869 - Flags: approval-mozilla-aurora+
has problems to apply to aurora

merging config/external/icu/data/icudt58l.dat
warning: /sheriffs/trees/uplift/mozilla-central/config/external/icu/data/icudt58l.dat looks like a binary file.
warning: conflicts while merging config/external/icu/data/icudt58l.dat! (edit, then use 'hg resolve --mark')
abort: unresolved conflicts, can't continue
Flags: needinfo?(andrebargull)
Hmm, that's strange. I can apply the patch without any conflicts:
---
andre@VBdev:~/hg/mozilla-aurora$ hg tip
changeset:   375832:e428ad55a704
tag:         tip
fxtree:      aurora
user:        Carsten "Tomcat" Book <cbook@mozilla.com>
date:        Mon Apr 10 14:49:38 2017 +0200
summary:     Backed out changeset ecbabf4c7f8d (bug 1353975) for bustage
andre@VBdev:~/hg/mozilla-aurora$ hg pull -u
pulling from https://hg.mozilla.org/releases/mozilla-aurora/
searching for changes
no changes found
andre@VBdev:~/hg/mozilla-aurora$ hg qimport -n test-tzdata2017b https://bugzilla.mozilla.org/attachment.cgi?id=8854869
adding test-tzdata2017b to series file
andre@VBdev:~/hg/mozilla-aurora$ hg qpush --move test-tzdata2017b
applying test-tzdata2017b
now at: test-tzdata2017b
---
Flags: needinfo?(andrebargull)
I believe it would be nice to also update this on Forefox 52 ESR.
Comment on attachment 8854869 [details] [diff] [review]
bug1353649.patch

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration:
User impact if declined: See comment #6.
Fix Landed on Version: mozilla53/54/55.
Risk to taking this patch (and alternatives if risky): See comment #6.
String or UUID changes made by this patch: None.
Attachment #8854869 - Flags: approval-mozilla-esr52?
(In reply to Alexandre Folle de Menezes from comment #12)
> I believe it would be nice to also update this on Forefox 52 ESR.

Yes, it is. Thanks for the reminder!
Comment on attachment 8854869 [details] [diff] [review]
bug1353649.patch

Based on the user impact mentioned in comment 6, let's uplift to ESR52.2
Attachment #8854869 - Flags: approval-mozilla-esr52? → approval-mozilla-esr52+
You need to log in before you can comment on or make changes to this bug.