[e10s] Tab title disappears indefinitely, and tab displays spinner after moving it to new window and back

UNCONFIRMED
Unassigned

Status

()

Firefox
Tabbed Browser
UNCONFIRMED
11 months ago
11 months ago

People

(Reporter: 684sigma, Unassigned)

Tracking

({multiprocess, regression})

50 Branch
multiprocess, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
While using Firefox Beta 52, I found a problem, that is also reproducible in Beta 53, Nightly 55.
After moving tabs to new window, sometimes they display spinner instead of the favicon, and after moving them back to original window, they replace the title with "Connecting...", even if the page isn't loading anything(!). I do this whenever I need to have an easily accessible tab, and probably in more cases
So, it doesn't always happen, but I was able to reproduce this in Nightly with these steps:

1. Launch clear Nightly profile, open new tab (Opened tabs: Firstrun page, Homepage, Newtab(selected))
2. Drag and drop tab with Homepage to move it to new window, then drag and drop it back to original window
3. Drag and drop tab with Firstrun page to move it to new window, then drag and drop it back to original window

Result: After moving to new window, each tab displays spinner. After moving it back, tab title is replaced with "Connecting..."
Expected: Each tab should display its original favicon and title

This is not Bug 1347389, because it doesn't involve any iframes, and the pages aren't even loading anything.
(Reporter)

Updated

11 months ago
Has STR: --- → yes
Keywords: regression
(Reporter)

Comment 1

11 months ago
Never happened in ESR 45, and doesn't happen with multiprocess disabled on later versions.

Updated

11 months ago
Keywords: multi-monitors

Comment 2

11 months ago
oops
Keywords: multi-monitors → multiprocess

Updated

11 months ago
See Also: → bug 1350324
(Reporter)

Comment 3

11 months ago
Mozregression-gui generated this regression range for scenario in Comment 0:
2017-01-24 - 2017-01-25
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a6ed4bb887b120a2987c5484ef9e48a32840748b&tochange=b2239bbe0c45b84159ea8f5359de473a07a4b3dc
->
1332202 – Crash in OOM | large | NS_ABORT_OOM | NS_EscapeURL
https://bugzilla.mozilla.org/show_bug.cgi?id=1332202
(Reporter)

Comment 4

11 months ago
Then I noticed that the scenario doesn't reproduce the bug on Beta 52, so I found another one:

1. Launch clear Nightly profile, open new tab, open http://bbc.com/
(Opened tabs: Firstrun page, Homepage, Newtab, http://bbc.com/ (selected))
2. Press Ctrl+Shift+R and keep moving the tab with Firstrun page to new window and back to its place in original window
3. When http://bbc.com/ loads to the end, repeat step 2

Result: Once after moving to new window, the tab displays spinner. After moving it back, tab title is replaced with "Connecting..."
Expected: tab should display its original favicon and title


Mozregression-gui generated this regression range for the second scenario:
2016-07-25 - 2016-07-26
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7c669d5d63efceb12696cd65cfa72c296013dafb&tochange=f44bb9de08ade45299223de89953c6d0f4d003d1
->
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=84b5a1027550faf65534d67dc02372ba09508550&tochange=80ab1089a326e4a35d32cd6f52ed0194eba89ecf
->
1261842 – Make initial browser remote sooner if we're defaulting to using remote tabs
https://bugzilla.mozilla.org/show_bug.cgi?id=1261842

After 2 full loads of http://bbc.com/ , the bug is 100% reproduced. On the last good build even after 5 full loads, the bug isn't reproducible.
Blocks: 1261842, 1332202
Has Regression Range: --- → yes
Version: 52 Branch → 50 Branch
You need to log in before you can comment on or make changes to this bug.