Hotstar Videos do not play in Firefox

NEW
Unassigned

Status

()

P3
normal
a year ago
a year ago

People

(Reporter: matrixisreal, Unassigned)

Tracking

Trunk
All
Unspecified
Points:
---

Firefox Tracking Flags

(firefox52 affected, firefox53 affected, firefox54 affected, firefox55 affected)

Details

(URL)

(Reporter)

Description

a year ago
STR
I'm not sure what the exact problem is, Hope someone can figure it out.
This might also be a duplicate.

STR : 

Play a HotStar video on firefox 
Ex : http://www.hotstar.com/tv/on-air-with-aib/6200/2-fast-2-dumb/1000171151
The video keeps on buffering and it doesnt play

THe Javascrpt and LOGS in Web Console :

          The page was reloaded, because the character encoding declaration of the HTML document was not found when prescanning the first 1024 bytes of the file. The encoding declaration needs to be moved to be within the first 1024 bytes of the file.  1000171151:1
A call to document.write() from an asynchronously-loaded external script was ignored.  B10412108.139077272;sz=1x2;ord=283819160:1
A call to document.write() from an asynchronously-loaded external script was ignored.  B10412108.139077272;sz=1x2;ord=283819160:148
HTTP “Content-Type” of “text/html” is not supported. Load of media resource http://www.hotstar.com/ failed.  1000171151
Cannot play media. No decoders for requested formats: text/html  1000171151
preload true  raven.min.js:2:1580
get content info  raven.min.js:2:1580
GETCDN:  false   null  raven.min.js:2:1580
get cdn  raven.min.js:2:1580
initialize player  raven.min.js:2:1580
received content info  raven.min.js:2:1580
wait since player is not ready  raven.min.js:2:1580
HTTP “Content-Type” of “text/html” is not supported. Load of media resource http://www.hotstar.com/ failed.  1000171151
Cannot play media. No decoders for requested formats: text/html, text/html  1000171151
fetching manifest  raven.min.js:2:1580
got cdn data:  true  raven.min.js:2:1580
manifest ready, waiting for player  raven.min.js:2:1580
3
external.03042017_0.14190113893710077_v5.0.40.js:34
HotstarPlayer v31.2.0304171  raven.min.js:2:1580
player ready  raven.min.js:2:1580
send content info already available to player  raven.min.js:2:1580
GETCDN:  true   Object { xml: "<smil><head><meta name="id" content…", userInfo: null }  raven.min.js:2:1580
Use of getPreventDefault() is deprecated.  Use defaultPrevented instead.  external.03042017_0.14190113893710077_v5.0.40.js:2:10381
send manifest to player  raven.min.js:2:1580

There doesn't seem to be any network stream.


Note:
Pretty sure this is not Hotstar specific and Hotstar related (as this works in chrome and other browsers.)
Component: Activity Streams: General → Untriaged
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0

Hello and thanks for the report!

Following the STR from comment 0, I was able to reproduce the issue using all Firefox channels, on Windows 10 and Ubuntu 16.04 platforms.
- On Windows 10 x64, the video seems to start loading, but after a couple of seconds, the following error message is displayed: "Sorry, we are unable to serve your request at this time. Please try again later. [102100:45]"
- On Ubuntu 16.04 LTS x64, there is no error message displayed and the video is not loading at all.
Severity: critical → normal
status-firefox52: --- → affected
status-firefox53: --- → affected
status-firefox54: --- → affected
status-firefox55: --- → affected
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
Hardware: Unspecified → All
Version: unspecified → Trunk
It looks like a Flash issue.
(Reporter)

Comment 3

a year ago
(In reply to JW Wang [:jwwang] [:jw_wang] from comment #2)
> It looks like a Flash issue.

Yeah, I guess
A proper error message for the same would be useful, as in this case the users aren't notified of anything and the video seems to be buffering.
Not an issue with HTML video. Moving to plugins.
Component: Audio/Video: Playback → Plug-ins

Updated

a year ago
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.