Treestatus HTTP 500s for unknown repositories

RESOLVED FIXED

Status

Release Engineering
TreeStatus
RESOLVED FIXED
11 months ago
10 months ago

People

(Reporter: emorley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
$ curl -I https://treestatus.mozilla-releng.net/trees/fxapom
HTTP/1.1 500 Internal Server Error
Server: Cowboy
Date: Wed, 05 Apr 2017 14:41:34 GMT
Connection: keep-alive
Content-Type: text/html
Content-Length: 141
Via: 1.1 vegur

$ curl -I https://treestatus.mozilla-releng.net/trees/
HTTP/1.1 500 Internal Server Error
Server: Cowboy
Date: Wed, 05 Apr 2017 14:45:23 GMT
Connection: keep-alive
Content-Type: text/html
Content-Length: 141
Via: 1.1 vegur

In addition, the HTTP 500 is missing the CORS header, so consumers like Treeherder don't see the HTTP 500 but the equivalent of a network timeout instead:

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://treestatus.mozilla-releng.net/trees/fxapom. (Reason: CORS header 'Access-Control-Allow-Origin' missing).
(Reporter)

Updated

10 months ago
Duplicate of this bug: 1356420
(Reporter)

Comment 2

10 months ago
Fixed by:
https://github.com/mozilla-releng/services/commit/51d7e0c3ab3ce9b556d5eea592810553b70e214e
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
:emorley:

This landed in mozilla-releng/services master, but I'm waiting with releasing it until Tue (after holidays).
:emorley: this was now deployed
You need to log in before you can comment on or make changes to this bug.