Closed Bug 1354020 Opened 3 years ago Closed 3 years ago

Use per-monitor v2 on Creators Update

Categories

(Core :: Widget: Win32, defect)

All
Windows 10
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla55
Tracking Status
firefox55 --- verified

People

(Reporter: emk, Assigned: emk)

References

()

Details

Attachments

(1 file)

Per-monitor v2 will make workarounds unnecessary that bug 1254026 introduced.
* Win32 dialogs such as file chooser will scale automatically.
* Non-client area will scale automatically.
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
OS: Unspecified → Windows 10
Hardware: Unspecified → All
Comment on attachment 8855540 [details]
Bug 1354020 - Use per-monitor v2 on Creators Update.

https://reviewboard.mozilla.org/r/127370/#review130504

Patch looks reasonable to me. I'd suggest specifically requesting some extra QA attention here, on both pre- and post-Creators Update versions of Windows, given that we don't have automated test coverage, and it's not really possible to cover all potential configurations while developing a patch.
Attachment #8855540 - Flags: review?(jfkthame) → review+
How can I request a QA? (Sorry for the dumb question.)
Flags: needinfo?(jfkthame)
Depends on: 1354785
Steps to reproduce:
1. Set the operating system scaling factor to 100%.
2. Sign out and sign in again.
3. Set the operating system scaling factor to 200%, but do NOT sign out.
4. Launch the patched build.
5. Press Ctrl+O to open a file picker.

Expected result:
On Creators Update, the file picker will be correctly scaled and crisp.
On Anniversary Update, the file picker will be scaled but blurry.
On earlier versions of Windows 10 or Windows 8.1, the file picker will be crisp but tiny.
Windows 7 can not change the scaling factor without log off, so this STR is not applicable.
Setting qawanted, as we don't have automated test coverage for this stuff; also ni? to Bogdan, who has helped with DPI-related testing in the past.

Besides the specific STR for this bug as described in comment 4, please be alert for any apparently resolution/scaling-dependent glitches that may appear, across different Windows releases and multi-monitor/mixed-DPI configurations. Thanks!
Flags: needinfo?(jfkthame) → needinfo?(bogdan.maris)
Keywords: qawanted
The most possible glitches would be blurry text or incorrectly scaled UI elements. On Windows 8.1+ with mixed-DPI monitors, please drag Firefox windows across monitors to verify that windows are rescaled correctly.

Process Explorer would be useful to verify the DPI awareness. Right click the column header of the process view and select "DPI awareness" to see the DPI awareness. On Windows 7, the DPI awareness should be "System aware". On Windows 8.1 or later, the DPI awareness should be "Per-monitor aware". Unfortunately, Process Explorer does not recognize per-monitor v2 yet. So it is impossible to distinguish it from per-monitor v1 using Process Explorer.
Pushed by VYV03354@nifty.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/5da187560ed9
Use per-monitor v2 on Creators Update. r=jfkthame
https://hg.mozilla.org/mozilla-central/rev/5da187560ed9
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Sorry for the late testing here, I had a lot on my plate lately.

I just finished testing on Windows 8.1 64bit and Windows 10 64bit and I did not see any glitches, blurry text, UI issues. 

Setup used:
- Low resolution monitor (WSXGA Samsung 2233)
- High resolution monitor (Dell UHD-1 P2415Qb)

Tested scenarios:
- Dragging Fx window between screens
- Checked Fx menus, pop-ups, infobars
- Visited a number of websites with rich content
- Used Process Explorer to see the value of DPI awareness for Fx 55. (It was 'Per-monitor aware' for W8.1 and W10, W7 'System aware' exactly as expected)
- All the scenarios from above were ran with different DPI and screen rez configurations.

Possible issue:
Only thing I saw are these artifacts but they occur after changing the dpi of the high resolution monitor from any value to 200 and did NOT sign out (only W8.1). After signing out and back in the artifact disappeared. 
Here is a screenshot of what I am seeing: https://www.dropbox.com/s/36tv3v6tgzmme7y/Artifacts%20W8.1.png?dl=0

Other then that, all looks good from QA point of view. Please let me know about the issue mentioned above (since windows suggests to sign out and back in to avoid issues like that I think it's no issue here but just to be sure).
Status: RESOLVED → VERIFIED
Flags: needinfo?(bogdan.maris) → needinfo?(VYV03354)
Keywords: qawanted
I also have a regression range for the issue from above:

Narrowed inbound regression window from [fdfb1d87, c3771535] (3 revisions) to [14593086, c3771535] (2 revisions) (~1 steps left)
Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=c3771535a47ebb8260de3362188c83790831867e&full=1

Pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=7452e706f98556cec41158761f700b84d726ec98&tochange=75582480f7824c82d82e5b6111cccd1066cb0745

Found commit message:

Bug 1289143 - Apply the appropriate scaling to window edges when processing WM_NCCALCSIZE for a window on a secondary screen with non-system DPI. r=emk

Let me know if I should log a new bug on this.
Please file a new bug. This bug should have no effect on Windows 8.1.
Flags: needinfo?(VYV03354)
(In reply to Masatoshi Kimura [:emk] from comment #11)
> Please file a new bug. This bug should have no effect on Windows 8.1.

Thanks! I logged bug 1361758 for this.
Depends on: 1390097
You need to log in before you can comment on or make changes to this bug.