If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Attaching the debugger to child processes in Visual Studio results in 'Rust GDB' error

RESOLVED INVALID

Status

()

Core
Build Config
RESOLVED INVALID
6 months ago
6 months ago

People

(Reporter: jimm, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox55 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 months ago
Created attachment 8855281 [details]
error dialog.jpg

This regressed in the last few weeks. VS will generate this dialog for each process you attach to. Debugging native doesn't appear affected but the warning here is pretty scary, so, there's that. I'll test to see if this is webrenderer related.

error message:

Failed to attach to these types of code:
Rust GDB: A serious internal error occurred while processing this command. The debugger may be unstable now. It is recommended that you save all files and exit.
What VS version are you using?  Doesn't happen to me.  I'm using Spawned Process Catcher X (https://www.janbambas.cz/automatically-attaching-child-test-spawned-firefox-processes-visual-studio-ide/)
(Reporter)

Comment 2

6 months ago
(In reply to Honza Bambas (:mayhemer) from comment #1)
> What VS version are you using?  Doesn't happen to me.  I'm using Spawned
> Process Catcher X
> (https://www.janbambas.cz/automatically-attaching-child-test-spawned-firefox-
> processes-visual-studio-ide/)

2015 with update 3. I'll try to add-in to see if it works around the issue. Maybe attaching at startup avoids this somehow.
(In reply to Jim Mathies [:jimm] from comment #2)
> 2015 with update 3. I'll try to add-in to see if it works around the issue.
> Maybe attaching at startup avoids this somehow.

Same version and I'm attaching to plugin-container.exe regularly.
(Reporter)

Comment 4

6 months ago
Caused by a Visual Studio extension named Visual Rust.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → INVALID
(Reporter)

Comment 5

6 months ago
(In reply to Honza Bambas (:mayhemer) from comment #3)
> (In reply to Jim Mathies [:jimm] from comment #2)
> > 2015 with update 3. I'll try to add-in to see if it works around the issue.
> > Maybe attaching at startup avoids this somehow.
> 
> Same version and I'm attaching to plugin-container.exe regularly.

thanks for the debugging help!
You need to log in before you can comment on or make changes to this bug.